Upgrade from Backup Exec for Windows Servers 10d to Backup Exec 11d or above fails because the MSDE upgrade to SQL Express fails (Error 29552)

Article:TECH70004  |  Created: 2009-01-27  |  Updated: 2012-10-24  |  Article URL http://www.symantec.com/docs/TECH70004
Article Type
Technical Solution

Product(s)

Problem



Upgrade from Backup Exec for Windows Servers 10d to Backup Exec 11d or above fails because the MSDE upgrade to SQL Express fails.


Error



V-225-53: ERROR: Failed to install SQL Express BKUPEXEC instance with error 29552.

The Installation log (BKUPInst.htm) will show an error related to SQL similar to the following:
 
V-225-53: ERROR: Failed to install SQL Express BKUPEXEC instance with error 29552. ***To search for information about this error, click here
 
(C:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec\Logs\Bkupinst.htm)
 

The error above can occur during an upgrade or repair of the Backup Exec Installation.  If the error is ignored during an upgrade, the update may complete partially, Backup Exec can appear to function afterward, but the installation will pointing to an MSDE instance, because SQL Express failed to update MSDE.

 


Cause



SQL files are missing which are required to upgrade MSDE to SQL Express.


Solution



1. Copy BPAClient.dll file from C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA\Bin to C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA.
2. Run a repair of the Backup Exec Installation. 

Supplemental Materials

SourceError Code
Value29552
Description

Failed to install SQL Express BKUPEXEC instance.


SourceUMI
ValueV-225-53
Description

ERROR: Failed to install SQL Express BKUPEXEC instance with error 29552


SourceEvent ID
Value10005
Description

Product: Microsoft SQL Server 2005 Express Edition -- Error 29552. UpgradeAdvisor returned  -1 .
 



Legacy ID



323745


Article URL http://www.symantec.com/docs/TECH70004


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