Unable to set backup mode after a Building Blocks failover

Article:TECH70251  |  Created: 2009-01-05  |  Updated: 2014-03-25  |  Article URL http://www.symantec.com/docs/TECH70251
Article Type
Technical Solution

Product(s)

Issue



After performing a Building Blocks failover, in an Active / Passive configuration, the following error is generated when trying to set or clear the backup mode, using either the Vault Admin Console process, or Powershell
 


Error



Type: Error
Event: 7046
Source: Enterprise Vault
Category: Storage Management
Description:
Unable to set Vault Store Backup Mode.
Reason:The parameter is incorrect. [0x80070057]
VaultStoreGroupEntryId: 1D735BBE7A644C2418C5136AE706B48CC1013300LDNVault
Name: Default Upgrade Group
V-437-7046

A DTRACE of the StorageManagement process reports the following:

23 11:52:29.317 [9576] (StorageManagement) <7940> EV:M HRXEX fn trace :|Source : .\StorageManage.cpp (CStorageManage::UpdateVaultStoreBackupMode) [lines {4006,4013,4061}] built Nov 27 20:39:19 2008|Description: Call error 0x80070057 |ref[1]: Storage service entry id specified is different to the current Storage service entry id.
24 11:52:29.333 [9576] (StorageManagement) <7940> EV:M CStorageManage:: UpdateVaultStoreBackupMode (Exit) |Exception occurred. [0x80020009] |
25 11:52:29.333 [9576] (StorageManagement) <7940> EV~E Event ID: 7046 Unable to set Vault Store Backup Mode. |Reason:The parameter is incorrect. [0x80070057] |VaultStoreEntryId: 195F2BFC1B349474DB88E80FA977D9C811210000LDNVault |Name: Archive |


Solution



Workaround:
Use the legacy method of backing up Enterprise Vault. Some example scripts are shown below and more information can be found in the Enterprise Vault 2007 Administrators Guide.

SAMPLE BATCH FILES AND REGISTRY KEYS FOR BACKUPS
These examples should be customized to each specific environment and server; remove references to services that are not present on the specific Enterprise Vault server and ensure all other relevant services and processes are accounted for before testing. Save Registry files with a .reg extension and ensure the name and paths of the Registry files matches the name and paths in the batch files.

PREBACKUP.BAT:
REM ---------------------------------
REM prebackup.bat
REM ---------------------------------
net stop /y "Enterprise Vault Task Controller Service"
net stop /y "Enterprise Vault Storage Service"
net stop /y "Enterprise Vault Indexing Service"
net stop /y "Enterprise Vault Shopping Service"
regedit /s c:\readonly.reg
net start "Enterprise Vault Storage Service"
net start "Enterprise Vault Indexing Service"
net start "Enterprise Vault Shopping Service"
net start "Enterprise Vault Task Controller Service"

POSTBACKUP.BAT:
REM ---------------------------------
REM postbackup.bat
REM ---------------------------------
net stop /y "Enterprise Vault Storage Service"
net stop /y "Enterprise Vault Indexing Service"
net stop /y "Enterprise Vault Task Controller Service"
regedit /s c:\normal.reg
net start "Enterprise Vault Storage Service"
net start "Enterprise Vault Indexing Service"
net start "Enterprise Vault Task Controller Service"

Sample Registry File to Place Services in a Read Only Mode
[HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Storage]
"EnableArchive"=dword:00000000
"EnableExpiry"=dword:00000000
"EnableFileWatch"=dword:00000000
"EnableReplayIndex"=dword:00000000
"EnableNSFMigrations"=dword:00000000  [For Lotus Domino Sites Only!]
"EnableCrawler"=dword:00000000
"EnablePSTMigrations"=dword:00000000

Sample Registry File to Return Services to Normal Mode
[HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Storage]
"EnableArchive"=dword:00000001
"EnableExpiry"=dword:00000001
"EnableFileWatch"=dword:00000001
"EnableReplayIndex"=dword:00000001
"EnableNSFMigrations"=dword:00000001   [For Lotus Domino Sites Only!]
"EnableCrawler"=dword:00000001
"EnablePSTMigrations"=dword:00000001

 
 

This issue has been resolved in the following release:

Enterprise Vault 9.0.3

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.

There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. However, the issue is currently scheduled to be addressed in the next major revision of the product. Please be sure to refer back to this document periodically as any changes to the status of the defect will be reflected here.  Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Symantec Sales, please see  http://www.symantec.com .
 

Supplemental Materials

SourceEvent ID
Value7046
Description

Unable to set Vault Store Backup Mode. Reason:The parameter is incorrect. [0x80070057]


SourceETrack
Value1596605
Description

Unable to set/clear backup mode in a Building Blocks configuration.


Legacy ID



324052


Article URL http://www.symantec.com/docs/TECH70251


Terms of use for this information are found in Legal Notices