Unable to install Backup Exec on Windows server 2003 or a Server 2008 due to a corrupt MDAC installation. Installation fails with"You must install MDAC 2.8 or later before you can install Backup Exec."

Article:TECH70963  |  Created: 2009-01-28  |  Updated: 2011-07-13  |  Article URL http://www.symantec.com/docs/TECH70963
Article Type
Technical Solution



Issue



Installation fails with"You must install MDAC 2.8 or later before you can install Backup Exec."


Error



You must install MDAC 2.8 or later before you can install Backup Exec.


Solution



For Windows Server 2003:
       - Click on Start > Run INF and click Ok
       - Look for mdac.inf, right click on the file and click install
       - Provide the Windows OS CD or the Service pack 2 CD if prompted.
       - Once MDAC is installed, continue with the Backup Exec installation.
    
For Windows Server 2008:
 Windows Server 2008 uses WDAC. This error message is an indicator that the existing WDAC files are corrupt.
        - Open a command prompt.
        - Run the command: SFC/SCANNOW
This command scans the integrity of all protected system files and repairs or replaces incorrect versions with correct Microsoft versions.
       - A reboot of the system is recommended.
After performing this command the WDAC files are repaired or replaced and will allow for the BEWS installation to complete without the error condition.
 


Legacy ID



325723


Article URL http://www.symantec.com/docs/TECH70963


Terms of use for this information are found in Legal Notices