Backup jobs fail when trying to use a dedicated backup network.

Article:TECH73316  |  Created: 2009-01-09  |  Updated: 2014-07-09  |  Article URL http://www.symantec.com/docs/TECH73316
Article Type
Technical Solution


Issue



 Backup jobs fail when trying to use a dedicated backup network.
 


Error



Final error: 0xe0000f02 - The media server could not connect to the remote computer. The remote computer may not exist on the selected subnet. Try an alternative network interface, or allow Backup Exec to choose any available network interface.
 


Environment



Backup networks are commonly configured by placing entries for each remote server in the hosts file of the backup server, and then adding the backup server entry to the hosts file of each remote server.
 


Cause



If Backup Exec is already configured and running on a production network at the time the backup network is built, the network information will already be cached in the Backup Exec Database (BEDB).
 


Solution



SOLUTION 1 - Verify Hosts file

Edit the Hosts file on Media server and the Remote server by following the below steps :
 
1. Open the hosts file located at %SystemRoot%\system32\drivers\etc\ by using an text editor such as Notepad.
 
%SystemRoot% refers to the drive where the Windows system files are located (C:\Windows by default).
 
Note:Alternatively, Host file can be opened from the run command>
Go to Run>Type Drivers
then Go to etc folder, inside the etc folder host file is listed.
 
2. Comment out the line that references the IPv6 address.
(This may be used for troubleshooting, to understand the scope of the issue, however it is highly discouraged.  IPV6 is a core componant of newer operating systems such as server 2008 and the primary network protocol going forward.)
 
# :::1 localhost
 
3. Add the following lines into the file:
 
127.0.0.1 hostname_of_the_computer 
127.0.0.1 hostname.FQDN (Fully Qualified Domain Name) 
Local_IPv4_address hostname_of_the_computer 
Local_IPv4_address hostname.domain.FQDN 
Remote_IPv4_address hostname_of_the_remote server 
Remote_IPv4_address FQDN_of_the_remote server
 
4. Save the changes made to the file and restart the Backup Exec Services.
 
Solution 2 - Clear NRDS entries in other backup exec database
 
If all the hosts entries are correct (verified by pinging the remote server from the backup server to see what IP gets used), then it may be necessary to clear the cached information in the database. 
Editing a SQL database shoud be performed by a trained SQL administrator. It is highly recommended to take a copy of the database prior to a manual edit. 
 
On the Backup Server:
 
1. Launch SQL Server Management Studio.
(Management studio can be downloaded from http://www.microsoft.com/download/en/details.aspx?id=8961 )
2. Open the BEDB.
3. Open the NRDS.dbo table.
4. Find the entry with the hostname for the remote server in question and delete the entire row.
 
If this field repopulates and causes the issue to return, disable publishing on the remote server.
 
On the Remote Server:
 
1. Launch the Backup Exec Remote Agent Utility
2. Click >Publishing >Change Settings
3 Click >Publishing, Uncheck "Enable Remote Agent to Publish..."   This will prevent the NRDS.dbo table from being repopulated with network information from the remote server. 

Supplemental Materials

SourceUMI
ValueV-79-57344-3842
Description

The media server could not connect to the remote computer. The remote computer may not exist on the selected subnet, but the option to use any available network route was not selected.


SourceError Code
Value0xe0000f02
Description

The media server could not connect to the remote computer.



Legacy ID



329571


Article URL http://www.symantec.com/docs/TECH73316


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