V-76-58645-10246- Some of the volumes in the disk group did not arrive from PNP within the time period

Article:TECH73677  |  Created: 2009-01-21  |  Updated: 2010-08-14  |  Article URL http://www.symantec.com/docs/TECH73677
Article Type
Technical Solution

Product(s)

Environment

Issue



This issue can show up in several manners, e.g.

- MountV resources fail to online
- Microsoft Cluster Volume Manager Diskgroup (VMDg) resources come online but resources dependant on the VMDgs then fail because the volumes are not yet available
- Diskgroup import errors report that volumes fails to arrive from PnP in vm_vxisis.log
 


Error



CDdlprov: vdid_initialize() failed (1002).
LoadProvider: load failed for provider ddlprov. error = 0xc1000001

Followed by:

vxvm-OpLog:  -- Error(e5152806) : Some of the volume(s) in the diskgroup did not arrive from PNP within the timeout period.


Cause



Please check Veritas Enterprise Administrator --> StorageAgent --> Providers and check if the DDL Provider failed, see screenshot below:

To confirm why the provider is failed check the vm_vxisis.log and identify the last startup:

14/06/2009 22:23:09:3908:LoadProvider: loading provider ddlprov from location C:\Progra~1\Veritas\Veritas Volume Manager 5.0\providers\ddlprov.dll
14/06/2009 22:23:09:3908:CDdlprov: vdid_initialize() failed (1002).
14/06/2009 22:23:09:3908:LoadProvider: load failed for provider ddlprov. error = 0xc1000001
 


Solution



Confirm that the VDID binaries are in place in both paths

%VMPATH%\bin
%VMPATH%\vc7\bin

If the Binaries are missing they can be copied in from a working system to fix the problem. If they are in place the next step would be to check the Registry keys.

For Storage Foundation 5.1 x86:

[HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\VRTSvdid]
"InstallDir"="C:\\Program Files\\Veritas\\Veritas Volume Manager 5.1\\"
"version"="1.2.279.0"


For Storage Foundation 5.1 x64:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Veritas\VRTSvdid]
"InstallDir"="C:\\Program Files\\Veritas\\Veritas Volume Manager 5.1\\"
"version"="1.2.279.0"


For Storage Foundation 5.0 x86:

[HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\VRTSvdid]
"InstallDir"="C:\\Progra~1\\Veritas\\Veritas Volume Manager 5.0\\"
"version"="1.2.221.0"

For Storage Foundation 5.0 x64:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Veritas\VRTSvdid]
"InstallDir"="C:\\Progra~1\\Veritas\\Veritas Volume Manager 5.0\\"
"version"="1.2.221.0"
 
If the registry key is missing, please add them manually as per the format above. Alternatively,  implement the registry fix found in the following article: TECH136174.



Legacy ID



330001


Article URL http://www.symantec.com/docs/TECH73677


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