When a password string is including [@] character, Oracle backups may fail with TNS error

Article:TECH74287  |  Created: 2009-01-08  |  Updated: 2014-07-25  |  Article URL http://www.symantec.com/docs/TECH74287
Article Type
Technical Solution

Product(s)

Issue



When a password string is including [@] character, Oracle backups may fail with TNS error


Error



ORA-12154: TNS:could not resolve the connect identifier specified


Solution



Oracle backups can fail with TNS error when all the following conditions are met:
1. A logon account is specified for not only an oracle server but also an Oracle database. (Figure 1)
2. The logon account for the oracle database is including [@] character.

Figure 1
 

Cause:

The logon account for the oracle database is used for that RMAN connects to a target database.
For instance, when the user name is [scott] and the password is [t@iger], RMAN will connect to the database as follows:
C:> RAMN target scott/t@iger
In this scenario, RMAN will connect to [iger] database and fail in the TNS name resolution.

If the Oracle database has OS authentication, the account for RMAN is not needed. In this scenario, RMAN will connect to the database as follows:
C:> RAMN target /


Resolution:

To resolve this issue please perform one of the following:
A. Clear the logon account for the oracle database if the OS authentication is enabled.
B. Change the password without [@] character.



Legacy ID



331493


Article URL http://www.symantec.com/docs/TECH74287


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