An alert 'ODBC access error' is observed every time the Backup Exec services start and the restore selections are not complete.

Article:TECH75279  |  Created: 2009-01-06  |  Updated: 2011-06-21  |  Article URL http://www.symantec.com/docs/TECH75279
Article Type
Technical Solution

Product(s)

Environment

Issue



Every time Backup Exec (BE) services start, the following Errors are observed in the Alerts tab. (Figure 1).  In addition, the restore selections may not be able to be browsed or may not be displayed at all when trying to create a new restore job.

 



Error



ODBC access error. Possible lost connection to database or unssuccessful access to catalog index in the database

Figure 1: 

 


Cause



This can occur due to connection issues to the Backup Exec database or corrupt catalogs in the Catalog folder.  It can also occur after an upgrade of Backup Exec if the catalogs have not been upgraded completely from the past version.

 


Solution



1. Backup Exec Database (BEDD) is hosted on an invalid SQL Instance.
 
Solution: First make sure the SQL instance being used for the BEDB is a valid Instance. This by default is SQL Express but could be a full version of SQL. If the instance is a SQL MSDE 2000 instance that was not upgraded to SQL Express, this is the problem.
 
Install another instance with SQL Express installer. Located in the BE install files WINNT\Install\SQLExpress\
 
Then use BEUtility to move BEDB to the SQL Express instance,
  • Open BEUtility,
  • Select All Media Servers
  • On the right column right click the Media Server name 
  • Select New Backup Exec Database location
  • In the box enter the ServerName\NewSQLInstanceName 

2. Corrupt database index of catalogs.
 
Solution: Run CatRebuildIndex to rebuild the Catalog indexes. (Figure 2)
  • Stop all BE Services
  • Open command prompt and browse to x:\Program Files\Symantec\Backup Exec
  • Run "CatRebuildIndex -r".
  • Start all BE services.
 Figure 2:
 
 

3. Corrupt catalogs from upgrades of Backup Exec.
 
Solution:
  • Stop all Backup Exec services.
  • Open a command prompt and browse to x:Program Files\Symantec\Backup Exec
  • Run the following SQL scripts to update the catalogs.
  • Replace ServerName\BkupExec with the server name and sql instance name.

 

osql -E -S servername\BkupExec -dbedb -icatupgrade_10.sql

osql -E -S servername\BkupExec -dbedb -icatupgrade_11.sql

osql -E -S servername\BkupExec -dbedb -icatupgrade_11_1.sql

osql -E -S servername\BkupExec -dbedb -icatupgrade_12_0.sql

osql -E -S servername\BkupExec -dbedb -icatupgrade_12_5.sql

osql -E -S servername\BkupExec -dbedb -icatupgrade_13_0.sql

catrebuildindex -r

 

Note : Run the scripts only up to the previous Backup Exec version. 
Examples
If the current Backup Exec version is 12.0, run the osql scripts up to the 11_1 version and then run the "catrebuildindex -r".
If the current Backup Exec version is 12.5, run the osql scripts up to the 12_0 version and then run the "catrebuildindex -r".
If the current Backup Exec version is 2010, run the osql scripts up to the 12_5 version and then run the "catrebuildindex -r".
If the current Backup Exec version is 2010 R2 or 2010 R3, run the osql scripts up to the 13_0 version and then run the "catrebuildindex -r".
 
 

4. Corrupt catalogs in the Catalogs folder.

If the above steps do not correct the catalog issue, it may be necessary to start with a fresh catalog database.  This step should only be taken as a last resort as it will result in a blank catalog database with no restore selections available.

Solution:

  • Stop all Backup Exec services.
  • Rename the Catalogs folder to Catalogs_OLD (default location - x:\Program Files\Symantec\Backup Exec\)
  • Run the steps from Solution 2 above.
  • Start all BE services. A new Catalogs folder will be created.
  • At this point no catalogs are present as this is a new, blank Catalogs folder.
  • It will be necessary to run a Catalog job on each piece of media prior to running any restore or duplicate job on that media. 

 



Legacy ID



334732


Article URL http://www.symantec.com/docs/TECH75279


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