Backup of a VMWare virtual machine using the Agent for VMWare Virtual Infrastructure (AVVI) fails with the error: "Final error: 0xe0008488 - Access is denied."

Article:TECH75322  |  Created: 2009-01-07  |  Updated: 2012-11-16  |  Article URL http://www.symantec.com/docs/TECH75322
Article Type
Technical Solution


Issue



Backup of a VMWare virtual machine using the Agent for VMWare Virtual Infrastructure (AVVI) fails with the error: "Final error: 0xe0008488 - Access is denied."


Error



Final error: 0xe0008488 - Access is denied.

UMI-V-79-57344-33928


Environment



The backup of a Virtual Machine (VM) using AVVI may fail with the above mentioned error if one or more of the following points may apply:

  1. The backup only fails if the Granular Restore Technology (GRT) option for the AVVI agent is enabled in the backup job properties.
  2. The backup job log may also log errors "V-79-57344-65033 - Directory not found. Cannot backup directory_name and its subdirectories."
  3. In addition to the previous errors, the backup job log may also show warnings like "V-79-57344-38724 - Directory 'D\HomeDirs\userprofile' does not support Granular Recovery Technology (GRT).  Granular restores cannot be performed for items in this directory."
  4. The problem is most likely to occur on backing up the largest VM, but could happen for smaller VM as well.
  5. The System Event logs on the server acting as the VMWare Consolidated Backup (VCB) proxy may show the following events.

    - Event 26 from "Application Popup":
    "Delayed Write Failed, Windows was unable to save all the data for the file C:\WINDOWS\Temp\BEV15.tmp\digits\1\Temp\Test\TestFile. The data has been lost. This error may be caused by a failure of your computer hardware or network connection."
    - Event 50 from "ntfs"
    - Event 57 from "vstor3bus"
  6. It is possible that the system acting as the VCB proxy shows "Out of Disk Space" messages for the System Drive (typically c:)

Cause



The root cause of the above mentioned problem may be lack of available free space  on the C:\ drive of the system acting as VCB proxy. Most likely the free space is consumed by the VMWare REDO file that gets created as part of the operation of the mountvm.exe command. This command is part of the VCB framework. Backup Exec calls on the mountvm.exe command during the GRT phase of an AVVI backup. Additional information on the REDO file can be found in  http://kb.vmware.com/kb/1003231 (The REDO file can grow to several GB in size)


 


Solution



Change the TMP and TEMP system variables on the system acting as VCB proxy to point to a drive with a lot more free space. This will cause the REDO file to be generated on that drive.

To change the TMP and TEMP system variables:
  1. On the system acting as VCB proxy, go into "System Properties".Select the "Advanced" tab and click the "Environment Variables" button.
  2. In the "System Variables" section at the bottom of the screen, change the paths for the TMP and TEMP variables. Point the variables to a volume with ample free space (possibly more than 10GB free).
  3. Reboot the server for the changes to take effect, re-run the backup and verify the results.

Supplemental Materials

SourceUMI
Valuev-79-57344-33928
Description

Access is denied


SourceError Code
Value0xe0008488
Description

0xe0008488 - Access is denied



Legacy ID



334782


Article URL http://www.symantec.com/docs/TECH75322


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