Preflight Analysis does not work

Article:TECH7564  |  Created: 2005-09-06  |  Updated: 2005-09-07  |  Article URL http://www.symantec.com/docs/TECH7564
Article Type
Technical Solution

Issue



Error "Workbench is unable to connect to the Preflight Analysis server. Specify a valid URL." when attempting to start Preflight Analysis tool. Details of error says "Failed to retrieve token from server."

However, using a browser to reach "http://MyServer/Wise_Preflight_Analysis/" works. In addition, BUT, nothing seems to be reported. And this is my second problem. Why is nothing reported? I have created a preflight MSI package and installed it on two computers with access to the webserver, but as I said, nothing seems to be reported.

Environment



Any version of Internet Information System


Cause



There are a number of possible causes - mainly involving installation configuration, IIS configuration or registry permissions.


Solution



If connection to the Preflight Database does not work after installing Wise Package Studio 5.x use the following as troubleshooting tips:
  1. If you click on the Preflight Analysis tool in WPS 5.x and receive a Connection Failed dialog window saying it cannot connect to \\servername\/Wise_Preflight_Analysis the reason for the failure may be the configuration chosen during the installation. If you entered the following path on the Preflight Path dialog during installation \\ServerName\C$\Inetpub\wwwroot\WiseSolutions\Preflight Analysis the connection may fail.
    Leaving it as the default (C:\Inetpub\wwwroot\WiseSolutions\Preflight Analysis) should resolve the problem.
  2. The best option is to use Windows Authentication during installation for Preflight Database setup. Select Allow anonymous access.
  3. Open Internet Explorer and select Tools > Options from the menu bar. Select the Advanced tab and Enable "Show friendly HTTP errors" by marking the box.
  4. Open the IIS control panel through the Administration Tools. Turn on Allow Unknown ISAPI extensions and Enable Active Server Pages.
  5. Verify the users for the server by opening Computer Management through the Administration Tools. Verify that the IUSR account throughout the system and for WPS are the same. If you don't have the same IUSR account configured, a connection to the Preflight Database cannot be established. It is possible in reimaged environments that the IUSR account will not match because the machine name may not be the same on each machine refresh.
  6. Check permissions in the Registry for the IUSR on this key (HKLM\Software\Wise Solutions) and subkeys. These should have full control.
  7. In IIS give Read Permissions to the Wise_Managed_Enterprise for the IUSR account. In some cases it may not have any permissions by default.
  8. Verify the Wise Preflight Analysis virtual directory in IIS looks OK (no errors).
  9. Make sure the IUSR account in SQL has rights to access the Preflight database and verify the account is enabled and access to the SQL database with db_writer and db_reader permissions.
  10. Clear the Internet Explorer cache. Simply open the browser, Click Tools from the menu. Click Internet Options. Click both Delete Files and Delete Cookies buttons.

Advanced Configurations (should only be performed by a Database Administrator or someone with access and knowledge of database tables):

  1. In the Workbench Database open the WebTool table and check that the URL column has the correct path to the Wise Preflight Analysis page. In the Flags column you can overwrite the value by entering a 0 in place of the 2. This forces the token to be true all the time. In addition, you can NULL out the TokenServerURL column. When you access the Preflight page it should default to the location of the WiseWebServices.dll file. A sample of the Preflight entry is below.
    43 http://WSRV2003ENT/Wise_Preflight_Analysis/ 2 http://WSRV2003ENT/Wise_Managed_Enterprise/WiseWebService.dll
  2. With WPS 5.1, open the default.asp file located in Inetpub\wwwroot\Wise Solutions\Wise_Preflight_Analysis folder in Notepad. Locate the following entry and make the following modifications. This forces the token to be TRUE at all times.
    Find this Session("S_IsBrowserKeyOk") = validator.IsValid(strToken)
    Replace with this Session("S_IsBrowserKeyOk") = True 'validator.IsValid(strToken)

Legacy ID



1556


Article URL http://www.symantec.com/docs/TECH7564


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