When trying to install Backup Exec Remote Agent, Windows reports error "1719 The Windows Installer service could not be accessed"

Article:TECH77631  |  Created: 2009-01-05  |  Updated: 2011-09-07  |  Article URL http://www.symantec.com/docs/TECH77631
Article Type
Technical Solution


Issue



During installation of Backup Exec Remote Agent on the remote server the following error is generated if installation is performed by doing RDP (Remote Desktop) session into the remote server

 


Error



Error 1719. The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not currently installed. Contact your support personnel for assistance.


Cause



This error can occur if a newer version of RDP is used.

 


Solution



To resolve this issue start the RDP session using the "mstsc /admin" to have proper permissions doing a RDP session and then try the installation of Remote agent again.

Note: In case the above step does not resolve the issue on x64 bit machines, try the following step:

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 

1. Change the registry key for WOW64 to 0 from 1 under the path HKLM\SYSTEM\CurrentControlSet\Services\msiserver.
2. Perform the installation of the Remote Agent.



Legacy ID



338194


Article URL http://www.symantec.com/docs/TECH77631


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