Determining the maximum number of concurrent users that Symantec Web Security can manage
| Article:TECH80886 | | | Created: 2003-01-11 | | | Updated: 2010-08-26 | | | Article URL http://www.symantec.com/docs/TECH80886 |
Problem
You need to know how to determine how many users a single Symantec Web Security server can manage.
Cause
high latency, High Usage users will cause slowness with SWS
Solution
There is no specific method of determining how many users a Symantec Web Security server can manage. Symantec Web Security manages connections from each user as threads. The user interface displays this information as HTTP connections. Each active user accessing the Internet will use an average of five threads at a time.
Depending on your network, these threads terminate as the page loads and can become available to other users. If your network experiences a high latency (delay) or uses a caching system between the users and the Symantec Web Security server, the termination of these threads on a per user basis increases the delay and causes performance issues. In addition, enabling client revalidation can severely impact performance as the number of users increases.
The type of user also is a factor in determining how many users a Symantec Web Security server can handle. When users are heavy Internet users, your network may need multiple servers to handle the load. For example, if you have an office of 50 users who constantly download large amounts of data from the Internet, they may require more connections than an office of 100 users who primarily use the Internet to check email and news. In each case, the number of connections required will vary. Other factors that can affect server management are dial-up users or users in remote locations. These types of users can cause threads to remain open for a longer than normal amount of time.
A Symantec Web Security server administrator can check the number of users and threads in use at a given time by using the following URL:
http://
The following screen shot shows the result of using the above URL:

The following is an explanation of the sessions and Active HTTP threads that are displayed:
Sessions: This is the number of authenticated users
Active HTTP Threads: This is a count of how many threads that are in use at a given time. If the maximum is being reached, it may be possible to raise the number of available threads or connections.
NOTE: The HTTPS threads count does not count how many HTTPS sites the users are currently visiting.
To modify HTTP server threads (connections)
- Open the Symantec Web Security Administration window.
- Click System > Modify.
- Select Built-in HTTP server options.
- Click Next .
The Modify System dialog box appears:

- Type a new number in the Maximum Number of Simultaneous Connections box.
- These do not place limits on the numbers of users, just the number of available connections.
The limit on the number of threads is actually 250 (as noted in the software documentation). It should be noted that the average Web site will cause the software to temporarily use five or more threads. These threads closed as the page is loaded. Imagine a page with text and four graphics, the text represents one thread, and each graphic uses one thread, these threads close as the text and graphics load. - Click Finish.
Restart is not required because Symantec Web Security updates dynamically.
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Legacy ID
2003021108581854
Article URL http://www.symantec.com/docs/TECH80886
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