How to manually register the license for Premium AntiSpam with Symantec Mail Security for Microsoft Exchange (SMSMSE)

Article:TECH83135  |  Created: 2005-01-10  |  Updated: 2011-10-19  |  Article URL http://www.symantec.com/docs/TECH83135
Article Type
Technical Solution


Problem



SMSMSE requires a separate license to enable Symantec Premium AntiSpam (SPA). This article provides a walkthrough on how to manually register the license for SPA.

NOTE: Registering the SPA license requires Internet access on port 443.



 


Cause



There are some Microsoft Exchange environments where direct Internet access is not available or you need to manually register the license.


Solution



Perform the following steps to manually register the SPA license with SMSMSE.

1. Download the attachment manualregister.zip to the SMSMSE server and unzip the files to a directory.
2. Open a command prompt and CD to the directory where the files are unzipped.
3. Run the following command to run the manual registration script:

.\manualregister.bat

NOTE:  If a proxy server is required for Internet Access use the following command:

            .\manualregister.bat -p <proxyserver:proxyport> -a <proxyuser:proxypassword>


        Where the following is true:


                <proxyserver:proxyport> is the IP address and port combination for your proxy server, separated by a colon (:).
                <proxyuser:proxypassword> is the user name and password, separated by a colon(:) of a user with administrator rights
                

NOTE: If a username and password is used the proxy server must use Basic Authentication. If the proxy uses Windows Integrated authentication then the credentials from the Windows account running the register command are used and passed along to the proxy.

The following is an example of the output from a successful run of the script:

Renaming file C:\Program Files\Symantec\SMSMSE\6.5\Server\SpamPrevention\bmiconig.xml to C:\Program Files\Symantec\SMSMSE\6.5\Server\SpamPrevention\bmiconfig.ml.1319048773
Creating file C:\Program Files\Symantec\SMSMSE\6.5\Server\SpamPrevention\bmiconig.xml with new settings
Running register command:
register -c "C:\Program Files\Symantec\SMSMSE\6.5\Server\SpamPrevention\bmiconfg.xml" -L "C:\Program Files\Symantec\SMSMSE\6.5\Server\SpamPrevention\SPALicens.slf"
Registration Successful.
You are now enabled to retrieve Brightmail rules
Stopping SMSMSE service
The Symantec Mail Security for Microsoft Exchange service is stopping........
The Symantec Mail Security for Microsoft Exchange service was stopped successfuly.

Starting SMSMSE service
The Symantec Mail Security for Microsoft Exchange service is starting......
The Symantec Mail Security for Microsoft Exchange service was started successfuly.

Stopping SMSMSE Utility service
The Symantec Mail Security Utility Service service is stopping.
The Symantec Mail Security Utility Service service was stopped successfully.

Starting SMSMSE Utility service
The Symantec Mail Security Utility Service service is starting.
The Symantec Mail Security Utility Service service was started successfully.

4. Exit the command prompt.


Technical Information

How to Register using the SMSMSE Administration Console

1. Open SMSMSE Administration console.
2. Expand Tasks.
3. Click Install/Renew License.
4. If necessary, follow steps 1 and 2 of the Install/Renew Licenses panel to request a license file from Symantec.
5. In step 3 of the Install/Renew Licenses panel, do one of the following:

a. Type the fully qualified path to the license file, and then click Next.

NOTE: If the license file does not reside on the same computer, you can specify a mapped drive or UNC path to the file.

b. Click Browse, select the license file, and then click Next.

NOTE: If the License File does not reside on the same computer, you can locate the file using My Network Places.

6. Click Install to install the license file to the server.
   

You can install the virus content and Symantec Premium AntiSpam license one after the other.
 

What's happening behind the scenes

This script automates the following steps:

1. CD to the SMSMSE installation directory.
2. Fix the issue described in this article: "Unable to save registration data to your disk" When Attempting to Manually Register a Premium AntiSpam License for Symantec Mail Security for Microsoft Exchange.
2. Run the following command:

register -c SpamPrevention\bmiconfig.xml -L SpamPrevention\SPAlicense.slf

3. Set the value of the registry key HKEY_LOCAL_MACHINE\Software\Wow6432Node\Symantec\SMSMSE\<version>\Licensing\SpaRunRegister to zero.
 


Attachments

manualregister.zip (1.8 MBytes)


Legacy ID



2005021009424954


Article URL http://www.symantec.com/docs/TECH83135


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