Error message: "The filer received status message Internal server error and error code [0x5] from vscan"
| Article:TECH85171 | | | Created: 2006-01-28 | | | Updated: 2012-10-10 | | | Article URL http://www.symantec.com/docs/TECH85171 |
Problem
Symptoms
You use Symantec AntiVirus Scan Engine on in RPC mode to scan your Network Attached Storage (NAS) device. Users cannot access a file on the NAS device and you see the following error message in the NAS device log:
"The filer received status message Internal server error and error code [0x5] from vscan"
You do not see an error message in the event viewer on the Symantec AntiVirus Scan Engine server.
Cause
A file permissions issue, or the file being accessed is corrupted.
This can also happend to clean files which Scan Engine is unable to scan.
This error has also been seen when Symantec Scan Engine is configured to send infected files to a Central Quarantine, and this Central Quarantine is full.
Solution
File permissions issue
This problem occurs when the NAS device cannot provide Symantec AntiVirus Scan Engine with access to the file. To resolve the problem, ensure that the Symantec AntiVirus Scan Engine service has full permissions to all of the files that are on the NAS device.
If Symantec AntiVirus Scan Engine is denied access to the file for scanning, the filer prevents client access to the file and reports the error.
You may also decide to permit access to specific file extensions on the NAS device without Symantec AntiVirus Scan Engine scanning.
Corrupt file issue
If the problem is not due to permissions it is possible that the file could be corrupt. This file should be removed from the Filer and further examined to confirm that it is a corrupt file.
Scan Engine unable to scan the file issue
Allow access to these files using the one-liner
java -jar xmlmodifier.jar -s //protocol/AllowAccessOnScanError/@value true configuration.xml
Central Quarantine is full
Make sure the Central Quarantine has ample room for submissions from Symantec Scan Engine
Technical Information
Because the problem occurs prior to the file scan, Symantec AntiVirus Scan Engine does not make a log entry for the error.
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Legacy ID
2006112810435654
Article URL http://www.symantec.com/docs/TECH85171
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