An attempt to a restore Mailbox/Public Folder on an Exchange 2007 server running on a Windows 2008 from a Granular Recovery Technology (GRT) enabled Backup-To-Disk set fails with the error "Unable to attach to a resource."
| Article:TECH86155 | | | Created: 2009-01-03 | | | Updated: 2012-04-23 | | | Article URL http://www.symantec.com/docs/TECH86155 |
Problem
An attempt to a restore Mailbox/Public Folder on an Exchange 2007 server running on a Windows 2008 from a Granular Recovery Technology (GRT) enabled Backup-To-Disk set fails with the error "Unable to attach to a resource."
Error
Error in Job Log :
Unable to attach to a resource. Make sure that all selected resources exist and are online, and then try again.
If the Information Store backup job is targeted to tape it fails with the following error:
Backup- \\Exchange2007\Microsoft Information Store\First Storage Group
V-79-57344-33928 - Access Denied. Cannot backup directory ?Mailbox Database and its subdirectories.
Error in Debug Log :
Example debug from a Single Exchange 2007 Server Topology :
m2chgdir: Logon failed without Last error set
MB2_Chgdir:Logon returned e000fea9
Cause
- The above problem occurs as a result of Windows 2008 using Internet Protocol version 6 (IPv6) as a preferred protocol over Internet Protocol version4 (IPv4).
- The Exchange 2007 application while running on a Windows 2008 machine listens on the usual ports 6001, 6002 and 6004 on the IPv4 address, but listens only on ports 6001 and 6002 on its IPv6 address. The DSProxy service (port 6004) is NOT listening on the IPv6 stack.
- Because Windows 2008 prefers IPv6 over IPv4, it talks to itself over IPv6. So when the RPC-over-HTTP Proxy tries to connect a user session to port 6004 on the same server, it tries to connect to :::1:6004 and NOT to 127.0.0.1:6004. Because the server is not listening to port 6004 on the IPv6 stack, the connection fails.
NOTE:
This issue can also occur if the Media Server is on a Windows 2008 server and Exchange 2007 is installed on a Windows 2003 64bit.
Solution
For a single-server topology where the Client Access server role is running on the same Exchange server as the Mailbox server role :
- Open the hosts file located at %SystemRoot%\system32\drivers\etc\ by using an editor such as Notepad :
%SystemRoot% refers to the drive where the Windows system files are located.
- Comment out the line that references the IPv6 address :
# :::1 localhost
- Add the following lines into the file:
127.0.0.1 hostname of the computer
127.0.0.1 FQDN of the computer actual
IPv4 address hostname of the computer actual
IPv4 address FQDN of the computer
- Save the changes made to the file and restart the Backup Exec services on the Exchange server.
- Run an Information Store backup/restore and verify the results.
- Under Network Connections, select the network adapter, and then click Properties.
- In the properties window, uncheck the check box for Internet Protocol Version 6 (IPv6).
- Click on the Start menu, and then click Run. Type regedit in the Open box.
- Using Registry Editor, locate the following registry key:
HKEY_Local_Machine\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
Warning:
Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
- Right-click the Parameters key, click New, and then click DWORD (32-bit) Value. For the key, add the following values: Name: DisabledComponents Data: 0xffffffff
- Restart the Client Access server (CAS).
- Run an Information Store backup/restore and verify the results.
|
|
| Source | ETrack |
| Value | 1317846 |
| Description | EXCH2K7: GRT Tape backup or B2D restores for E2K7 on Windows 2008 machines fail with MAPI errors. |
| Source | Error Code |
| Value | 0xe000848c |
| Description | Final error: - 0xe000848c Unable to attach to a resource. |
| Source | UMI |
| Value | V-79-57344-33932 |
| Description | Unable to attach to a resource. Make sure that all selected resources exist and are online, and then try again. If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource |
Related Articles
Legacy ID
306689
Article URL http://www.symantec.com/docs/TECH86155
Terms of use for this information are found in Legal Notices









Thank you.