IM Name Registrations Imported From LDAP Not Removed When IM Manager Changed to not Import Registrations from LDAP or Using a Different Attribute

Article:TECH86681  |  Created: 2006-01-23  |  Updated: 2011-02-11  |  Article URL http://www.symantec.com/docs/TECH86681
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Article Type
Technical Solution

Product(s)

Issue



IM Manager was configured to import IM names from an LDAP source.

IM Manager was reconfigured in one of the following ways:

  • Do not import IM name registrations from LDAP source
  • Change IM name registration from LDAP source to use a different attribute.  For example, configure AOL registrations from using mail attribute to using imname attribute.

However the IM names previously imported are still present in IM Manager.

Conditions

  • IM name registrations present for whose source is LDAP.
    1. Open the IM Manager Administration Console.
    2. Click the Administration tab.
    3. Click the User Management|Modify Users menu item.
    4. Select the protocol you are interested in from the Protocol dropdown.
    5. Click the Submit button.

    This condition is met if the Source column has the value of LDAPUpdate.
  • IM Manager is not configured to import IM names from LDAP or LDAP registration uses a different attribute
    1. Open the IM Manager Administration Console.
    2. Click the Settings tab.
    3. Click the LDAP Directory Integration|Field Selection menu item.
    4. Find the table Advanced Settings: Messages Table Mapping and Account Name Import.
    5. Find the row for the protocol you are interested in.

    This condition is met if the check box in the row for the protocol is not checked.  Or if the check box is checked the value of the dropdown Directory Fields for Import is different than configured previously.

 


Cause



IM Manager does not remove the LDAP registrations previously registered via LDAP registration.


Solution



This is a known limitation of IM Manager.  This article is updated as more information is available.  Subscribe to the article to receive updates.

Workaround

Note: Before using any SQL queries against your IM Manager database it is recommended that you perform a database backup.



To remove all LDAP registrations for a specific protocol

    1. Download the SQL script removeByProtocol.sql.
    2. Edit the script line SET @protocol = 'Microsoft Live Communications Server IM to the value of the IM protocol you want to remove. See the script for the appropriate values.
    3. Execute the script against the IM Manager database.



Attachments

removeByProtocol.sql (775 Bytes)

Supplemental Materials

SourceETrack
Value1494532
Description

ldap update does not remove imported IM names if synchronization is cleared


Legacy ID



2007532686650898


Article URL http://www.symantec.com/docs/TECH86681


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