Inventory Forwarding Causing 'Server is Busy' errors

Article:TECH8693  |  Created: 2005-12-09  |  Updated: 2005-12-09  |  Article URL http://www.symantec.com/docs/TECH8693
Article Type
Technical Solution


Issue



When attempting to forward inventory to a top tiered server, the A logs are full of "Server is Busy". Inventory Classes don't appear to have forwarded.

Environment



NS 6.0 SP2 HF 19, 15000 clients

Cause



The evtqslow queue on the top tiered server (destination server) has filled up with NSEs. The default registry values of a maximum file queue size of 512 MB is much to small as the NSEs from the inital inventory forwarding can be very large.

Solution



Modify the following registry keys:

HKLM/SOFTWARE/altiris/express/Notification Server/MaxFileQEventCount
default value 20000 files
HKLM/SOFTWARE/altiris/express/Notification Server/MaxFileQSize(KB)
default value 512000

If you have disk space, set the MaxFileQSize to a few gigabytes.

Legacy ID



16913


Article URL http://www.symantec.com/docs/TECH8693


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