Active backup job status shows as "Cancel Pending" for a long time and appear to be hung.

Article:TECH87507  |  Created: 2009-01-06  |  Updated: 2013-01-29  |  Article URL http://www.symantec.com/docs/TECH87507
Article Type
Technical Solution

Product(s)

Issue



When trying to cancel an active backup job, the status shows as "Cancel Pending" for a long period of time and may appear to be hung.


Cause



When trying to cancel an active job, the job status may show as "Cancel Pending" (see image below) for a long period of time.  Note that the time takes to cancel a running job varies depends on the activities run before the cancelling.  The cancelling job will stay in "Cancel Pending" until the activities timeout before the job terminated completely.  If the job stay in "Cancel Pending" for excessively long period of time, it may appear hung with the following reasons:

  • Backup Exec services not responding.
  • Process of cancellation stuck, and process still running.
  • Example, common behavior of applications when hung due to slow system performance .
  • Respond time of the process or service with the Operating System.

 

 


Solution



WARNING / NOTES:
  • Job needs to  be canceled  manually.
  • This method will cancel ALL jobs that are currently running.

STEPS:


 In the Backup Exec Console-:


1. Click on "Tools" > " Backup Exec Services" to open the servicesmgr.exe.
2. Click on "Restart all services" (In most cases, this process will get to the bengine service and appear hung).
3. Open Windows task manager and click on the "Processes" tab.
4. Enable "Show Processes from all users".
5. Click on the "Image Name" column to sort alphabetically.
6. Locate and highlight the following services.

  • Pvlsvr.exe  (Backup  Exec device and media service).
  • Bengine.exe  (Backup Exec job engine service).
  • Beremote.exe  (Backup Exec Remote Agent for Windows Server service).

7.Right Click on the above services in order and click on "End Process Tree" to terminate this process.

8.Close the task manager and return to the services manager.

9.After the services are terminated in Window,

10."Restart all services" process in the services manager should continue and complete.

Once this has completed, Open Backup Exec console and the backup job that was hung will no longer show in the active jobs.

Check the  Job history below. The canceled job will be displayed with the Error RPC services were restarted by user .No action required.



Legacy ID



322861


Article URL http://www.symantec.com/docs/TECH87507


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