Getting error after installing the NS Agent and when I try to open the UI for the Altiris Agent on the agent computer

Article:TECH8751  |  Created: 2005-12-12  |  Updated: 2006-04-18  |  Article URL http://www.symantec.com/docs/TECH8751
Article Type
Technical Solution


Issue



I'm getting the following after installing the NS Agent and when I try to open the UI for the Altiris Agent on the agent computer: 

Error activating agent session zero: plug-in not registered: object is not  registered(-2147220997).


Environment



NS 6.0 SP2

Cause



There was previously an agent installed and it was not removed completely.

Solution



To solve this issue, you'll need to uninstall and reinstall the agent manually. To do this, do the following:
  1. Run the following command line to remove the Altiris Agent using AeXAgentUtil.exe located by default at :\Program Files\Altiris\Altiris Agent\

    AeXAgentUtil.exe /uninstallagents /clean 

    This will remove all sub-agents and attempt to cleanly remove the Altiris Agent from the system.
  2. Delete the following Program files if still present: 

    C:\Program Files\Altiris\Altiris Agent
  3. Delete the following registry keys if they are still present: 

         HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | Altiris Agent 
         HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | eXpress ***DO NOT DELETE THIS key if you are removing the agent from the Notification Server itself.
         * HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | Scheduler
         * HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | APackageStub
         * HKEY_LOCAL_MACHINE | SOFTWARE | Classes | All sub items beginning with Altiris.
         * HKEY_LOCAL_MACHINE | SOFTWARE | Classes | AppID | {5E038245-CF81-44BE-8018-9A2981B9DC9B}
  4. Search in the Windows directory <WINDIR> using the string below and
    delete the found files:
        * AeX*

Legacy ID



16924


Article URL http://www.symantec.com/docs/TECH8751


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