LCS/OCS Tablet Messages are Appearing in the Recovery Queue
| Article:TECH89266 | | | Created: 2008-01-02 | | | Updated: 2012-02-28 | | | Article URL http://www.symantec.com/docs/TECH89266 |
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Problem
After using the KB: IMLogService Reports Error in Windows Application Event Log: A Message Retrieved From The Queue Exceeded The Set Maximum, LCS/OCS messages still appear in the Recovery Queue.
- For each message in the recovery queue there is a corresponding error message in the Application Event log similar to:
A message retrieved from the queue exceeded the set maximum message size. Confirm that the correct message queue is being used. If so, use the IMLog Enterprise MMC snap-in to increase the maximum message size.
Conditions
- IM Manager is deployed against Live Communications Server (LCS) or Office Communications Server (OCS).
- Examination of the messages show the content of the messages starting with "base64:".
- To verify this:
- 1. Use the following KB to extract the affected messages How to Extract IM Manager Messages from an MSMQ to a local directory.
2. Open the resulting CSV file with notepad.exe.
3. The phrase 'base64:' appearing in the message indicates this issue.
To put messages back into a Messaging Queue follow the steps in this KB: How to Write IM Manager Messages Into an IM Manager MSMQ.
Cause
Whiteboard or handwritten messages are encoded by LCS/OCS clients with a "base64:" message and are unusually large compared to normal messages. These messages are larger than the maximum message size defined by IM Manager.
Solution
Upgrade to IM Manager version 8.4.10 or later. This version of IM Manager increases the maximum message size of 200000 bytes per message.
Workaround
If the organization does not desire compliance then this issue can be ignored. The messages are not to the IM Manager database because they end up in the recovery queue.
If the organization does desire compliance it is recommended to block these messages. These messages are not reviewable in the IM Manager reviewer console.
To block the messages, add the following phrase to your IM Manager Content Filtering List:
- base64:
To do this follow these steps:
- Open the IM Manager Administration Console.
- Click on the Policies tab.
- Click on the Group Policy > All Rules menu item.
- Click on the blue edit button for the General Content Filtering Phrase List.
- In the text field enter: base64:
- In the drop-down selection, choose "Starts with".
- Press Add.
- Press Submit.
- Click on the blue edit button for the Content Filtering Action: General.
- Ensure that the "Enable Content Filtering" check box is marked.
- Select the Radio Button for "Block the Message".
- Press Submit.
References
How to Extract IM Manager Messages from an MSMQ
http://service1.symantec.com/support/ent-gate.nsf/docid/2007556753337498
How to Write IM Manager Messages Into an IM Manager MSMQ
http://service1.symantec.com/support/ent-gate.nsf/docid/2007402792006798
IMLogService Reports Error in Windows Application Event Log: A Message Retrieved From The Queue Exceeded The Set Maximum
http://service1.symantec.com/support/ent-gate.nsf/docid/2007525548279398
How to Troubleshoot Messages in the IM Manager Recovery Queue
http://service1.symantec.com/support/ent-gate.nsf/docid/2007110915301954
Technical Information
As of IM Manager version 8.4.10 the queue has a maximum message size of 200000 bytes per message. Prior to IM Manager version 8.4.10 the queue has a maximum message size of 100000 bytes per message.
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| Source | ETrack |
| Value | 1496779 |
| Description | The base64 message is logged with random characters when LCS is used with tablet PC |
Legacy ID
2008040209481754
Article URL http://www.symantec.com/docs/TECH89266
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