AIM 6.X and Higher IM Client Cannot Log in When IM Manager Is Not Listening on Port 443

Article:TECH89957  |  Created: 2008-01-23  |  Updated: 2014-05-08  |  Article URL http://www.symantec.com/docs/TECH89957
Article Type
Technical Solution

Product(s)

Issue



AIM 6.X and higher IM clients cannot log in.

Symptoms
Windows Application Event log may show the following error message:

 

      Listen failure on ip 0.0.0.0 (resolved to 0.0.0.0) and port 443 for AIM server endpoint ssl dispatch port. Possible cause is incorrect ip and port settings or the port could already be in use. Error code: 0x80004005.
    This message appears immediately after the IM Manager service IMLogRelayService starts up.


Conditions:
 

  • A process other than IM Manager is listening on IPs that AIM clients might connect to.
    1. On the AIM client computer perform a ping of the hostname provisioned with AOL to obtain the IP address.
    2. On the IM Manager computer perform the following command from a command prompt (for Windows 2003):
          netstat -a -n -b > netstat.txt
    3. Open the file netstat.txt in an editor.
    4. Look for LISTENING lines for port 443.

        Here is an example:
          TCP 0.0.0.0:443 0.0.0.0:0 LISTENING 3628
          [IMLogRelayService.exe]
        This line shows that the process IMLogRelayService.exe is listening on all available IPs on port 443.

        Here is another example:
          TCP 127.0.0.1:443 0.0.0.0:0 LISTENING 3628
          [System]
        This line shows an operating system component listening on IP 127.0.0.1 on port 443.
      If there are any lines that show a process other than IMLogRelayService.exe listening on an IP (or 0.0.0.0) for port 443 this condition is met.



 


Cause



IM Manager is not listening on the IP address and port that AOL clients are connecting on.


Solution



Configure the computer so that port 443 is available for IM Manager to listen on.
 

    Much of time it is IIS that is using port 443. If you do not need IIS to serve SSL pages then perform these steps to configure IIS to not use port 443:
      1. Open the IIS Administration Console.
      2. Open the Default Web Site folder.
      3. Right click on Default Web Site and select Properties.
      4. Delete any text in the SSL Port textbox.
      5. Click the OK button.
      6. From a command prompt restart IIS with this command: iisreset.


2. Restart the IM Manager service IMLogRelayService.
 

    NOTE: Restarting the IMLogRelayService incurs an outage for IM users.




References
How to Troubleshoot 6.X and Higher Login Problems

IM Manager Service IMLogRelayService Starts Up But Does not Listen on IM Ports: "Listen failure on ip"
Yahoo File Transfers Appears to Hang When IM Manager Not Listening on Port 80


Technical Information
There are situations where IIS starts listening on port 443 after installation of an SSL certificate. Use the steps in the following KB article to install the IM Manager certificate for use with AIM 6.X: How to Install an SSL Certificate for Use with IM Manager and AIM 6.X.

 


The most likely cause of this is IIS listening on port 443.


 



Legacy ID



2008072310345654


Article URL http://www.symantec.com/docs/TECH89957


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