Backup Exec Remote Agent for Windows Servers, fails to install on remote machine, installer error 1601 reported.
| Article:TECH93145 | | | Created: 2009-01-22 | | | Updated: 2012-09-20 | | | Article URL http://www.symantec.com/docs/TECH93145 |
Problem
Backup Exec Remote Agent for Windows Servers fails to install with "Windows Installer return error code: 1601" present in the bkupinst.log file on the remote machine.
Error
06-25-2003,18:45:31 : Windows Installer return error code: 1601
06-25-2003,18:45:31 : Call GetLastError Return Value:
06-25-2003,18:45:31 : Cannot create a file when that file already exists.
Cause
To troubleshoot an installation of the Backup Exec Remote Agent for Windows Servers, start with the bkupinst.log (bkupinst.htm) file found on the server in question in one of the following locations:
On Windows Server 2000/Server 2003/XP computers:
- Backup Exec 11.0 to present versions: Documents and Settings\All Users\Application Data\Symantec\Backup Exec\Logs
- Backup Exec 10.1 and earlier: C:\WINNT or C:\WINDOWS
On Windows Vista/Server 2008 computers, Bkupinst.htm is saved in: \\Users\All Users\Symantec\Backup Exec\Logs
*Vista/2008 is only supported in Backup Exec version 12.0 and newer*
For more information on the bkupinst log please refer to the administrator guide or the following links;
BE 12.0 - http://www.symantec.com/docs/299138
BE 12.5 - http://www.symantec.com/docs/HOWTO11660
If the log contains the error code "1601 - Cannot create a file when that file already exists" - then the Windows Installer service may be corrupt.
Solution
1. Try to start the Windows Installer service manually by opening the Computer Management console, and clicking Services. Select Windows Installer and then select Start (Figure 1)
Figure 1
2. If the service returns the error "193 %1 is not a valid Win32 application" then the service is corrupt
3. To attempt to repair the service, download Windows Installer 2.0 Redistributable for Windows NT 4.0 and 2000 from http://www.microsoft.com/downloads
4. Reinstall Windows Installer 2.0 Redistributable for Windows NT 4.0 and 2000
5. Reboot the computer
6. Reinstall the Backup Exec Remote Agent for Windows Servers
or
1. Check the Application Log for Event ID 1015 - error 0x80040154 - failed to connect to server
2. If that error is present, then re-register the Windows Installer service
3. To register the service, click Start | Run and then type msiexec /regserver
|
|
| Source | Error Code |
| Value | 1601 |
| Description | Windows Installer return error code: 1601. |
| Source | Event ID |
| Value | 1015 |
| Description | Failed to connect to server. |
| Source | Error Code |
| Value | 0x80040154 |
| Description | Failed to connect to server. |
Legacy ID
259539
Article URL http://www.symantec.com/docs/TECH93145
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