Manual Processes like Manual Scan or Manual LiveUpdate are not working.

Article:TECH94427  |  Created: 2009-01-09  |  Updated: 2012-01-25  |  Article URL http://www.symantec.com/docs/TECH94427
Article Type
Technical Solution

Product(s)

Environment

Issue



Is the connection being made to the settings database a local one or from the server?

Symptoms
There are some actions within the settings database that tell the product to do something now. Like running a manual LiveUpdate or manual scan. When pressing these buttons the product seems to ignore the buttons being pressed and does not proceed to do the task.


 


Cause



The connection being made to the settings database is local and not at the server. The customer who called this issue in was using the nlnotes.exe client with the server.id in order to have full access to the databases locally or through the server. Most admin clients setup by default to connect to a server which is where the product is installed so this is not an issue. But if using nlnotes.exe, you are on the server and therefore you have local access to the databases and can also connect to the databases through the server.


Solution



When opening (File/Database/Open) the settings database (sav.nsf), at the top of the dialog window there is a drop down listing for Server which is set to Local by default. Change this to the server name so that the database is opened by the server.



Technical Information
Our product has an extension manager (nnem.dll) that monitors events that are being generated at the server. Part of the events could be actions or changes within our own settings database. Actions like run LiveUpdate or run Manual Scan. When settings are changed and the documents are saved internally there is a NSFNoteUpdate() event that is triggered and when the product sees this event it knows the settings are changed and to change the behavior as per the new settings. This is why the settings (sav.nsf) database MUST be opened from the server and not locally in order to manage our product.


This can only happen with Lotus Domino loaded on a Microsoft Windows platform because this is the only platform where the Notes clients and Server software can run on the same machine. On other platforms like AIX for example you would connect to the server with a client that is loaded on a Windows machine. Being there is no Notes client that will run on AIX it is not possible to have a client that then has local access to the same databases as the server .

 



Legacy ID



2009060908362254


Article URL http://www.symantec.com/docs/TECH94427


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