Symantec Mail Security for Domino 7.5.x on Windows panics and crashes with customer sample on Domino 7

Article:TECH94952  |  Created: 2009-01-09  |  Updated: 2012-01-25  |  Article URL http://www.symantec.com/docs/TECH94952
Article Type
Technical Solution


Issue



Some mail message samples provided by the customer is causing Domino 7 to fail when our SMSDOM program calls NSFNoteOpenEx() from the Lotus Notes API with the third paramter set to 0.

Symptoms
The Domino server will panic and crash. If you look at the FATAL thread in the NSD you should see something similar to the following:



There are several things to point out here. At the top, highlighted in pink, we see that the fatal thread is NNTask. When this is seen by a customer they immediately think our software is the problem. In this case though something different is happening outside of our code. The lines of code our read from bottom to the top. Notice nntask at the bottom but then we call the NSFNoteOpenExt() function. This function is a Lotus Notes API function. The code for this is in the nnotes.dll library file which is why you see all the functions after this call coming from nnotes which is highlighted in yellow above. The last line at the top is a Panic occurring within nnotes and not our code. Lastly, if you look at the line highlighted in blue you can see the third parameter is set to 0.

 


Cause



We do not have the code for the Lotus Notes library and so we can not determine exactly why this failure is occurring. However, it appears that the failure is occurring when trying to free memory that was allocated in previous code. This problem requires IBM to fix. In Domino 8.0.1 and 8.0.2 we seen this same problem but the server did not crash, instead it hung in an endless loop. KB article 2008082518002254 was written for the Domino 8.0.1 and 8.0.2 issue.


Solution



As of the writing of this KB article there is no solution yet for this problem. The customer needs to open a PMR with IBM and request a hotfix. When this happens we can document the hotfix number in this KB article.



 


Supplemental Materials

Value1290443

Legacy ID



2009070911571054


Article URL http://www.symantec.com/docs/TECH94952


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