SACM client requires Rosetta to be installed in order to function with Mac OS X 10.6.x, Snow Leopard

Article:TECH97877  |  Created: 2009-01-03  |  Updated: 2010-08-05  |  Article URL http://www.symantec.com/docs/TECH97877
Article Type
Technical Solution


Issue



After installing the SACM Client daemon under Mac OS X 10.6.x, Snow Leopard or migrating an existing environment running the SACM Client daemon to Mac OS X 10.6.x there are a significant number of entries in the Mac OS X crash log. The SACM Client software may also not function as expected and stop communicating with the SACM console.

 


Cause



The SACM Client has dependencies on the Rosetta translator software. This software allows the execution of PowerPC-based code on an Intel-based Macintosh via emulation. Although this software was installed by default in prior Intel versions of Mac OS X, it is an optional install in Mac OS X 10.6. Rosetta is also removed from a system in a migration from an earlier Mac OS X build to Mac OS X 10.6.x.


Solution



Install Rosetta to allow the PowerPC code that the SACM Client daemon uses to allow the software to run without error and allow the workstation to communicate back to the SACM Console running under Mac OS X Server. Rosetta can be installed directly off the Mac OS X 10.6.x install DVD in the Optional Installs folder.

NOTE: SAV for Macintosh 10.2.3 does not have Rosetta dependencies and can operate without Rosetta being installed. However, the installer for SAV for Macintosh 10.2.3 requires Rosetta.



 

 


Supplemental Materials

SourceETrack
Value1909089

Legacy ID



2009120311193448


Article URL http://www.symantec.com/docs/TECH97877


Terms of use for this information are found in Legal Notices