Clients are not getting an updated configuration

Article:TECH9934  |  Created: 2005-12-21  |  Updated: 2006-03-17  |  Article URL http://www.symantec.com/docs/TECH9934
Article Type
Technical Solution


Issue



Client computers are not getting patches and have outdated inventory. The following errors are in the logs:

<event date='Jul 18 01:40:48' severity='1' hostName='SICTESTDC1' source='ConfigServer' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2444' thread='2832' tickCount='317861859' >
  <![CDATA[RequestPolicies failed: Unexpected response from URL HTTP://NTAPPSVR18.CORP.STANDARD.COM/ALTIRIS/NS/Agent/GetClientPolicies.aspx?xml=<Request configVersion="2"><WrkstaGuid>{B9E5A564-9879-4B63-B4CC-12B8E41898D0}</WrkstaGuid></Request>&compress=1&hash=1: Unable to locate a resource with the specified GUID (-2147213056)]]></event>
<event date='Jul 18 01:40:48' severity='4' hostName='SICTESTDC1' source='ConfigServer' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2444' thread='2832' tickCount='317861859' >
  <![CDATA[Computer not known to server, sending basic inventory]]></event>
<event date='Jul 18 01:40:50' severity='4' hostName='SICTESTDC1' source='ConfigServer' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2444' thread='2832' tickCount='317864750' >
  <![CDATA[Basic inventory update has been sent]]></event>
<event date='Jul 18 01:40:50' severity='4' hostName='SICTESTDC1' source='ServerSettings' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2444' thread='2832' tickCount='317864750' >
  <![CDATA[Next basic inventory update will be sent to server NTAPPSVR18.CORP.STANDARD.COM at 2005-07-25 01:40:50, in 10080 minutes]]></event>
<event date='Jul 18 01:40:50' severity='4' hostName='SICTESTDC1' source='ServerSettings' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='2444' thread='2832' tickCount='317864765' >
  <![CDATA[Next policy request from server NTAPPSVR18.CORP.STANDARD.COM will be at 2005-07-18 01:55:50, in 15 minutes]]></event>


Environment



Notification Server
Altiris Agent

Cause



The computer had not communicated with the Notification Server in the amount of time specified in the Purging Maintenance and had been retired.

This can also occur if a computer has been set to any status other than Active.


Solution



Find the computer in a report or in the Altiris Console by clicking the Resources tab > Resources > Defaults.

Right-click the row the computer is listed on, click Set Asset Status, and select the wanted status. (In this case it was changed from "Retired" to "Active".)

KB17212 has steps on how to create a notification that will notify if this situation happens in the future.

Legacy ID



17247


Article URL http://www.symantec.com/docs/TECH9934


Terms of use for this information are found in Legal Notices