pcAnywhere Agent will not install or will not register as a plug-in
| Article:TECH157725 | | | Created: 2011-04-08 | | | Updated: 2011-08-23 | | | Article URL http://www.symantec.com/docs/TECH157725 |
Problem
After upgrading the Symantec Management Agent from version 7.0.x to version 7.1.x, pcAnywhere will not install, or it installs but does not register as a plug-in with the Symantec Management Agent. Prior to the Symantec Management Agent upgrade, managed computers previously had pcAnywhere installed, either the corporate edition (known as the "box" or "boxed" version) or the pcAnywhere Agent plug-in.
Error
- the command "regsvr32 pcAAgent.dll" returns a message that that file doesn't exist
- pcASolInstaller-pcAClientInstallManager-TRACE.LOG reports: Failed to open SOFTWARE\Altiris\Altiris Agent\Plugin Objects\Agents\pcAAgent registry path, Error Code : 2
- pcAPluginAgentInstall.log reports: Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. {BD52ED7E-9843-45E6-99E8-7C5F79A1AAF9}
Cause
There were problems with the original release of pcAnywhere Solution 12.6 build 65 (12.6.65).
Solution
First, apply the patches attached to the first three articles under the ISSUES LIST section of the article entitled "How to find the latest information about pcAnywhere Solution 12.6" (http://www.symantec.com/docs/HOWTO42353).
To resolve the behavior on the managed computers which already have the pcAnywhere Agent installed, turn on the "pcAnywhere Plug-in for Windows - Upgrade" policy.
If the Upgrade policy does not correct the problems on managed computers which originally had pcAnywhere Agent version 12.6.65 installed, then try the following steps:
- Pick a filter that represents the machines needing pcAnywhere
- Clone the "pcAnywhere Plug-in for Windows - Uninstall"
- Edit that cloned policy to target the filter from step one above, and schedule the policy
- Let the policy run and ensure the host has been uninstalled from all machines
- Disable the cloned Uninstall policy and clone the "pcAnywhere Plug-in for Windows - Install" policy
- Use the filter from above, or the default filter "Windows computers with no pcAnywhere Plug-in Installed" if it targets the correct computers.
- Schedule the Install policy and let it run. The new pcAnywhere Agent installer, which is provided by one of the patches mentioned above, will resolve the installation errors described above.
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Article URL http://www.symantec.com/docs/TECH157725
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