Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange Server 2013’e geçiş sonrası Enterprise Vault’a dair yapılması gerekenler

Created: 12 May 2014
Baris Aydogmusoglu's picture
0 0 Votes
Login to vote
Merhaba,

Bir önceki yazımda Exchange Server 2010’dan Exchange Server 2013’e geçiş konusundan bahsetmiştim. http://www.aydogmusoglu.com/exchange-server-2010dan-exchange-server-2013e-geis.html

Bu yazımda yine aynı test ortamımdaki Enterprise Vault Cluster yapısının yeni Exchange Server 2013 server’ı arşivlemeye devam etmesi için yapılması gerekenlere ve çalışanların arşivlenmiş e-mail’lerine outlook wep app’ten erişmeye çalışırken karşılaşabilecekleri durumlara değinmek istiyorum. Exchange Server 2013, kullanıcının arşivlenmiş e-mail’lerine bakması sırasında Enterise Vault ile güvenli(SSL) kanaldan bağlantı kurmak eğilimindedir. Enterprise Vault’un yönetim rehberberinden yada kurulum rehberinden görebileceğiniz üzere sunucularınıza güvenilen bir otoriteden sertifika almalısınız. ( Enterprise Vault sunucusunun IIS manager’ından ilgili web site’e bind etmeyi unutmayın ). Enterprise Vault yapınız Cluster halinde ise cluster node’larına ilgili sertifikayı alınız.

Not: Enterprise Vault admin console’da site seviyesinde ssl enforcement yapmak zorunda değilsiniz. Exchange server’ınızda wildcard certificate kullanıyorsanız onu Enterprise Vault için de de kullanabilirsiniz ama güvenlik kuralları ve yaptırımlar derseniz yapınızın güvendiği bir otoriteden yeni dijital sertifika alınız.Ben lab ortamımda Exchange Server 2013’e aldığım dijital sertifikayı kullandım.

clip_image002

Benim yapımda Enterprise Vault yapısı Failover Cluster servisi üzerinde çalıştığından node1’de node2’de sertifika yapılandırmasını tamamladım. Bir tanesini örnek olması açısından üstte resmediyorum. Exchange Server 2010 tarafında bütün mailbox’ları (system mailbox vb. ) Exchange Server 2013’e aktarıp Exchange Server 2010’u silmiştim. Node’lardan birine Enterprise Vault admin account’u ile giriş yaptım. EV admin console’a baktığımda(aşağıdaki gibi) task’lerin başarısız olduğunu görüyorum. Çünkü target’lar arasında sadece eski Exchange Server 2010 var(sunucu ismi windc idi ama üzerindeki exchange server 2010’u uninstall etmiştim!).

clip_image004

İlaveten mailbox archiving task’ı da failed durumda. Normal. Sebebini önceki paragrafta anlatmıştım. clip_image006

Şimdi yeni target olarak yeni Exchange Server 2013’ü ve ona dair task’i tanımlayalım. Not: Provisioning task server level’da olmadığından(forest level’da) onunla bir sorunumuz yok. Sync işlemini yapabiliyor mu diyerekten log’ları gözlemeniz yeterli.Malumunuz üzere EV ürünü mailbox’ları provisioning task’i sayesinde konuşlandırıyor! Target olarak ekleyeceğiniz Exchange Server’ın bilgilerine isterseniz Exchange Admin Center’dan bakabilirsiniz. Ortamımdaki sunucunun ismi exch13.test.ev dir.

clip_image008

Enterprise Vault Admin Console’undan “Targets” altından yeni target ekleme sihirbazını başlatın. clip_image009

System Mailbox’ını soruyor. Bunu da daha önce Exchang Server 2010’dan Exchange Server 2013’e taşımıştım! Dolayısıyla seçebiliyorum. İsmi sysmbx’tir.

clip_image011

E-mail adresi ise sysmbx@test.ev ‘dir. Bir kaç “next” sonrasında yeni exchange server’ı da target olarak eklemiş oldum. Eski target’ı ( windc ) sileceğim. clip_image013

Yeni target için de mailbox archiving task oluştu( Target ekleme sihirbazı sonucunda ). clip_image015

Task özelliklerine bakmayı ihmal etmeyiniz. Değiştirmek istediğiniz kısımlar olabilir. Bildiğimiz gibi “site” sevisinde tanımlı bir takım ayarlar yada diğer ayarlar yapıdan yapıya değişiklik gösterebilir, bundan dolayı task’in özelliklerine göz atmakta fayda vardır. Sunucularınızın kaynaklarına göre aşağıdaki değerler ile oynanabilir!

clip_image017

Ardından task’i “start” edebilirsiniz. Enterprise Vault server yada server’lar üzerindeki MS Outlook ile bir kaç işlem yapalim ki olası sorunları olmadan önleyebilelim. Provisioning task’in log’una bakarsanız tamamlanmış. “Error” varsa mutlaka çözülmesi gerekir. Zira mailbox archiving task’te sorunlar yaşarsınız!

clip_image019

EV server’lardaki MS Outlook’u açarak mailbox server’a bağlantısını gözleyelim. EV server’lara EV Admin account’u ile giriş yaptığınızı varsayıyorum. Mesela EV admin kullanıcısı ile system mailbox’ı(sysmbx@test.ev) adına mail atabiliyormuyuz ? Yani EV admin kullanıcısının system mailbox üzerinde “Send As” hakkı var mı? Normalde Exchange Organization bazında daha önceki yapınızdan gelen haklar mevcut aslında. Bu önerdiğim sadece bir test gözlemidir! Bu arada MS Outlook cache mode’da iken yeni exchange server’a bağlantı sorunu yaşarsanız “Cache Mode” kutucuğunu temizleyip test edebilirsiniz. ( MAPI error’ler alabilirsiniz diyerekten belirttim ) EV admin account’u ile “send as” testinde ve system mailbox adına send/receive testlerinde sorun yoksa devam edebilirsiniz. Evet artık Mailbox Archiving task’ını çalıştırıp sync/run işlemini yapabiliriz! clip_image021

Üstte görüldüğü gibi sync kısmı tamamlandı.Şimdi de “Run”.

clip_image023

Yapımda 5 kullanıcıda arşivleme açıktı! Üstte görülüyor. Bir miktar arşivlik e-mail atmıştım aşağıdaki görebiliriz, task sonrasında arşivlenmiş! clip_image025

Arşivlemiş veriye EV Admin console’dan bakabiliriz.

clip_image027

“james@test.ev” ’in arşivine birşeyler gelmiş :) Burada çıkacak bir diğer sonuç ise Index servisi de sorunsuz çalışıyor :) Henüz neden olduğunu anlayamadım ama nadiren aşağıdaki hatalar ile kaşılaşabiliyorum.

clip_image028

Üstteki ile ilintili olarak bir tane de aşağıdaki gibi!

clip_image029

Bu hatalar için Symantec KB’ye bakarsanız çözüm şu şekilde. EV server’da IIS manager’dan Index application pool’unu recycle etmek! clip_image031

Neyse bu son bir kaç ifadeyi konudan bağımsız paylaştım.İşimize dönelim. James’in bir kaç e-mail’ini arşivlemiştim.James’in mailbox’ına Outlook WebApp’ten bağlanıp baktığımda arşivlenmiş e-mail’lere ve EV’ye dair bir ibare göremedim! Bu durum normal! clip_image033

Çünkü, henüz james@test.ev mailbox’i için EV Outlook MailApp aktif değil! Kullanıcılarınız arşivlenmiş e-mail’lere MailApp ile erişmek isterlerse ( MS Office 2013 ve OWA 2013 ile ) ilgili application’ı aktifleştirmelisiniz. Bu işlem bir kullanıcı için, bir “ou” altındakiler için yada exchange organizasyonu genelinde yapılabilir. james@test.ev için EV Outlook MailApp’i aktif edeyim. $Mbx = get-mailbox "james@test.ev" New-App -mailbox $Mbx.LegacyExchangeDN -Url ` ("http://vault.test.ev/EnterpriseVault/OfficeMailAppManifest.aspx?LegacyMbxDn=" + $Mbx.LegacyExchangeDN + "&BaseURL=https://externalarchive.test.ev/EnterpriseVault") Not: Üstteki script set’i external url’inde olacağını düşünerek ekledim. Sadece internal url adresi varsa EV setup yada admin rehberinden yada EV admin console’daki help’ten bakarak script’i kırpabilirsiniz.

**Aşağıda bahsettiğim ekstra bir durumdur**

Yapınızdaki internet erişimi yoksa(kapalı network’leri düşünebiliriz), kullanıcılarınız Outlook WebApp’dan yada MS Office Outlook 2013’ten arşivlenmiş e-mail’lerini açmak istediklerinde, EV MailApp’inin çalışmadığını gözleyebilirler. Account’u üzerinde EV MailApp’i aktifleştirilen kullanıcı arşivine erişmek istediğinde bir kaç web sayfasından bir takım *.js ‘ler yükleniyor(EV Server’da C:\Program Files (x86)\Enterprise Vault\WebApp\V10.0.3.1090\OfficeMailApp\redist\scripts dizini kullanılıyor). Eğer internet erişimi yoksa bunlar yüklenemiyor!( bir adet HTTP(S) Debugger ile baktım ) ( appsforoffice.microsoft.com:443 , ajax.aspnetcdn.com:443 adreslerine erişilmek isteniyor!)

clip_image035

SSL trafiğine baktığımda üstteki gibi tünel’in kurulamadığı ve bunun sebebinin de aşağıdaki gibi clip_image036

bağlantı probleminden olduğunu gördüm(Bendeki test lab’ı kapalı ağda olduğundan DNS Resolution olamıyor). Bundan dolayıda üstte belirttiğim sitelerden office.js , MicrosoftAjax.js,office_string.js vb.. *.js’ler download edilemiyor! Ben ilk iki *.js’i manuel olarak EV server’ın uygun dizinine koyduğum için trafik log’u office_string.js’e erişemediğini gösterdi ilk olarak J Lab’ım için internet erişimi sağladım ve trafik log’u aşağıdaki gibi. clip_image038

**Ekstra durum bitti**

Şimdi tekrar james@test.ev mailbox’ına Outlook WebApp ile giriş yaparsak; clip_image040

Enterprise Vault MailApp’inin çalıştığını ve arşivlemiş e-mail’lere erişebileceğimizi gözleyebiliriz.

Özet : Exchange 2013’e geçiş sonrası;

  • Enterirse Vault server’larınıza dijital sertifika alarak IIS’te ilgili virtual directory’ye bind ediniz.
  • Targets kısmından yeni exchange server’ları ekleyiniz - Provisioning task’i çalıştırınız.
  • Event Viewer’dan sonuçları gözleyiniz.
  • Varsa error’leri gideriniz.
  • Mailbox Archiving task’i çalıştırınız.SYNC ve RUN sonrası Event Viewer’ı kontrol ediniz.
  • Kullanıcılarınız için EV MailApp’i aktifleştiriniz ( arşivlenmiş e-mail’lere erişim için)
  • Outlook WebApp’ten veya MS Office Outlook 2013’ten arşivlenmiş e-mail’lere erişimi test ediniz. Sorun varsa bir HTTP(S) debugger ile gözleyiniz.

Yine bir yazının sonuna geldik. Umarım için yararlı olabilmişimdir.

Herkese sorunsuz ve neşeli günler dilerim…

Originally published by author at http://www.aydogmusoglu.com