Video Screencast Help
Endpoint Management Community Blog

After upgrading to MP1 adding credentials to an account fails - and various other SqlExceptions

Created: 12 Oct 2012 • Updated: 12 Oct 2012 • 2 comments
Ludovic Ferre's picture
0 0 Votes
Login to vote

A customer of mine reported a problem editing Security Accounts and associating credentials with account, or account to roles.

I had a look at the customer SMP logs and found that it was full of SqlExceptions.

We had a remote session on this today and found that the problem comes from SQL right for the account, which are not sysadmin on the SQL Server and could not read data in sys.syslockinfo, and this caused any call to spResourceAssociationsLoadData to fail.

Granting read on the sys.syslockinfo resolves the issue.

With that said, good week-end Connect!

Comments 2 CommentsJump to latest comment

mafoe's picture

Hi,

I have had the problem that the link in the menu to Account Management was completely missing, and also got lots of access denied errors in the console (as a Symantec Administrators Role Member). A Repair on the SMP in SIM did it (and did not brake the rest of the environment, but some settings for the Management Agent and TaskServers got defaulted I think).

 

Hope that could help

0
Login to vote
Ludovic Ferre's picture

The problem and recommended solution are now documented on Symwise:

http://www.symantec.com/docs/TECH198556

I am currently off-net, on a retreat of some kind. I'll be back real soon, and you sure will hear from me then ;-).

Ludovic FERRÉ
Principal Remote Product Specialist
Symantec

-7
Login to vote