Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Backup and Recovery Community Blog

BackupExec 2014 - Network interface resets for all jobs after reboot

Script Solution
Created: 15 Jul 2014 • Updated: 15 Jul 2014 • 1 comment
goli123's picture
+1 1 Vote
Login to vote

Hello everyone.

I'm not sure if it's only us that get this problem in the new backup exec (2014) but if it's not just us I would to share the workaround we found with you.

Our Backup exec servers have several network interfaces in different networks and we noticed that if not specified which network interface to use some of the jobs fails. We configured all of our backup jobs to use the correct interface but after we rebooted the server to install some updates we noticed that this settings were lost during the reboot. After a second reboot we saw this problem again and we decided to solve the issue via power-shell script that I'm going to share here with you.

To reset the right network interface to all of our jobs we used this code:

$inter = Get-BENetworkInterface InterfaceName
Get-BEBackupDefinition | Set-BEBackupDefinition -NetworkInterface $inter -NetworkProtocol IPv4 | Save-BEBackupDefinition -Force

After that we created a schedule task that runs 15 minutes after startup (to give chance for all the components to start properly) to run this 2 rows script. I hope this is use full to you.

 

Have fun, David.

Comments 1 CommentJump to latest comment

CraigV's picture

...nice share, thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

0
Login to vote