Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Archiving and eDiscovery Community Blog

Enterprise Vault Items Pending Indexing

Created: 17 Jul 2014
Rob.Wilcox's picture
0 0 Votes
Login to vote

Items Pending Indexing

From time to time you may get into a situation where indexing in Enterprise Vault is lagging behind. It happened to me just the other day when ingesting a large amount of data into some test archives. I'm sure of the exact trigger, but the net result was that the indexing service stopped. This didn't immediately cause me an issue, because the data was still added to the archive. But searching for the data was a bit tricky!

This can happen in a production environment too. Perhaps it's something you've encountered, or had escalated to you from the IT Helpdesk? 

A couple of handy SQL queries can help with figuring out if this is something that is affecting your environment:

select COUNT (*) from JournalArchive where IndexCommited = 0 

The output in my environment looked like this:

Image_11.png
The second query is used to figure out which archives are affected. Sometimes that's handy to know. That query is here:

select Records, ArchiveName
FROM
(select ArchivePoint .ArchivePointId, count(*)   Records
from journalarchive
inner join ArchivePoint on ArchivePoint .ArchivePointIdentity = JournalArchive.ArchivePointIdentity
where indexcommited= 0
group by JournalArchive.ArchivePointIdentity , ArchivePoint.ArchivePointId) SQ
INNER JOIN EnterpriseVaultDirectory.dbo .ArchiveView ON ArchiveView.VaultEntryId = SQ.ArchivePointId
order by Records desc

And the output looks like this:

Image2_3.png

Of course in my environment it was a simple matter of starting the indexing service and waiting for it to catch up.  It did take quite some time though.

Reference technote: http://www.symantec.com/business/support/index?page=content&id=HOWTO59167