Video Screencast Help
Storage & Clustering Community Blog

Error while configuring the custom application -- V-16-20081-3

Created: 06 Jun 2012 • Updated: 11 Jun 2014
Zahid.Haseeb's picture
0 2 Votes
Login to vote

Environment

Two ESXi Servers = Esxi1 and Esxi2

version of Esxi Servers = 5.0

Vcenter OS = Windows2008R2(64bit)

SAN = iscsi SAN attached on both Esxi Servers

HA and DRS = enabled

Application HA = 5.1 SP2

Application HA OS = rhel 5.6 (64bit)

Application name = sshd

 

Problem

I was facing the subjected error while configuring the Application under Symantec Application  HA. See the below snap as a reference:

 

Solution

There may be other culprits but in my case there were two things which was occuring.

1.) initially I was trying to configure Symantec Application HA on a OS which was configured as vmware FT. On the vmware FT this will not be applicable as per my understanding because the status is same of both VMs as primary VM and the partner VM are being replicated so if the status of application at primary site will change or fail the status will be replicated on the partner VM, so the partner VM cant up the application as the status is same.

2.) After configure the vmware HA instead of vmware FT I faced the same problem after few successful configuration of few applications under Symantec ApplicationHA.

I tried below listed things but did not help me:

a.) Switch the VM on different ESXi Server(I thought that this may be the problem and may resolve after changing the ESXi Server)

b.) Restarted the VM, restarted ESXi Servers/Vcenter Server/SAN.

This was fixed when I reinstalled the Symantec ApplicationHA Guest components on the VM.