Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Website Security Solutions

EV certificate compatibility and Firefox 3.5

Created: 02 Jul 2009 • Updated: 18 Dec 2012 • 1 comment
Tim Callan's picture
0 0 Votes
Login to vote

Hi folks. Sorry for the lack of posts lately. I've been slammed.

Writing today because Firefox 3.5 has broken the download record for a new browser version with over 8 million downloads in a single day. One subject that has been the source online discussion is the fact that the EV certificates for a series of SSL brands (four that I know of) have stopped showing up green in Firefox 3.5.

You can be assured that this problem does not happen with the EV SSL Certificates from VeriSign, thawte, or GeoTrust.

Comments 1 CommentJump to latest comment

Nick Wilsdon's picture

I'm even getting this for Verisign certificates on FF 3.0.12 on Ubuntu. Ebay for example - "arbd.ebay.com uses an invalid security certificate"

+6
Login to vote