Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.
Encryption Blog

Mac Users, Upgrading to OS X 10.6.8? You Want to Read This First...

Created: 11 Jul 2011 • Updated: 05 Nov 2012
Kelvin_Kwan's picture
0 0 Votes
Login to vote

 

We are once again writing to follow-up on our early post related to a similar issue from January.  This time, it’s for Mac OS X upgrades to Apple’s just released 10.6.8 update and PGP Whole Disk Encryption for Macs. 

Much like the previous post, Apple’s automated Mac OS X 10.6.8 Software Update mechanism bypasses the protections of PGP Corporation had put around a critical file needed for normal system startup.  This time however, users who are running 10.1.1-Build 10 and newer had no problems with the Apple 10.6.8 update as expected.  Users running older versions, however, ran into problems.

As communicated previously, the PGP Engineering team discovered that the Apple automated Software Update mechanism bypassed the protections PGP built-in to protect the boot.efi file.  This bypass allows the Mac OS X update to overwrite a critical file needed by PGP Whole Disk Encryption when the machine boots, thus rendering the system non-bootable after installation of the update. 

Users of PGP Desktop 10.1.1-Build 18 (or higher) did not run into any issues because PGP was able to properly protect the boot.efi file.  Users that were running an older version than PGP Desktop 10.1.1-Build 10 ran into problems because the new mechanism to protect the boot.efi file does not exist in those versions. While build 10 is not affected by some of the Mac update issues, it wasn't until Build 18 that we fixed the issue with a comoo updater for Mac as well.

We recommend that you please upgrade to PGP Desktop at least 10.1.1-Build 18 or higher prior to upgrading Mac OS X to 10.6.8.  This will prevent boot issues from this OS X upgrade. 

 

Latest Knowledge Base article pertaining to upgrading to OS X 10.6.8: http://www.symantec.com/business/support/index?page=content&id=TECH163224

 

For more information on how to obtain the latest version of PGP Desktop, please visit: 

http://www.symantec.com/business/support/resources/sites/BUSINESS/content/live/TECHNICAL_SOLUTION/163000/TECH163224/en_US/Obtain%20PGP%20Desktop.pdf

UPDATE:  If you are running SEE FDE for the Mac OS X platform, you must be on version 8.0.1 or higher.  If you upgrade to OS X 10.6.8 on SEE FDE 8.0.0, you will render your Mac non-bootable.