Video Screencast Help
Archiving and eDiscovery Community Blog

PSTDisableGrow and exporting archives from Enterprise Vault

Created: 21 Apr 2013 • Updated: 29 May 2014
Rob.Wilcox's picture
0 0 Votes
Login to vote

 

Have you ever had trouble exporting archives from Enterprise Vault?
 
I did the other day, and it was all down to PSTDisableGrow!  Yes, that's right, PSTDisableGrow - again.
 
What was happening was that I was using the Vault Admin Console, and right clicking the archives node, and choosing Export:
 
Image1.png
 
Then I was running through the normal steps in exporting an archive to a PST file, and the export starts:
 
Image2.png
 
And it progresses:
 
Image3.png
 
It takes some time ...
 
But in the end I'm done.
 
But then, I look at the PST file in the location I exported to, and it just 265 Kb.  An empty PST file!
 
So wow..  that's not right, not right at all.  I've given the game away, because I already know the answer.  PSTDisableGrow is set.  I've talked about PSTDisableGrow a few times before, but it isn't often I encounter it on the Enterprise Vault server.  You can see though from this run through that it has a huge negative effect on the server side of things, and is definitely something that should not be set.  The PSTDisableGrowAllowAuthenticodeOverrides won't help either in this situation.  This is because the Export Archive wizard has not been written with the override implemented.  In other words it's acting as just a really simple user...  no override... and hence it's hit by PSTDisableGrow, and no data can be added to the PST file.
 
In the situation on my demo environment I'd "cleverly" rolled out a GPO to all machines to set the PSTDisableGrow and the PSTDisableGrowAllowAuthenticodeOverride key, and not really thought about the Enterprise Vault server.
 
So the motto here ...  don't set PSTDisableGrow on your Enterprise Vault server, if you want to ever export archives to PST.