Video Screencast Help
Security Community Blog

SEP + Internet Explorer 9 beta = problemes?

Created: 28 Jan 2011
Maciej_Jedrzejczyk's picture
0 0 Votes
Login to vote

La réponse est immédiate - Oui.

Depuis l'apparition de la version beta d'Internet Explorer 9 nos clients nous contactent avec un souci particulier lors d'installation du client Symantec Endpoint Protection. Suite à l’installation sur Windows 7 64bit LiveUpdate montre que les définitions sont téléchargés avec succès. Malgré cela, le client SEP n’est pas à jour. Parfois, le problème est limité aux définitions de protection proactive contre les menaces réseau. Néanmoins, le problème persiste.

Bien que la desinstallation d'Internet Explorer 9 devient indispensable, ca vaut quand même de regarder les logs.

Alors, allons-y.

Les définitions ne sont pas à jour et cela peut seulement être confirme dans le fichier log.liveupdate qui se trouve dans C:\ProgramData\Symantec\LiveUpdate:

11/11/2010, 11:51:16 GMT -> Progress Update: TRIFILE_DOWNLOAD_END: Number of TRI files: "0"
11/11/2010, 11:51:16 GMT -> Progress Update: TRIFILE_DOWNLOAD_START: Number of TRI files: 3 Downloading Mini-TRI files
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantecliveupdate.com/automatic$20liveupdate_3.3.0.96_english_livetri.zip", Estimated Size: 0, Destination Folder: "C:\ProgramData\Symantec\LiveUpdate\Downloads"
11/11/2010, 11:51:16 GMT -> HttpSendRequest (status 404): Request failed - File does not exist on the server.
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantecliveupdate.com/automatic$20liveupdate_3.3.0.96_english_livetri.zip", Full Download Path: "C:\ProgramData\Symantec\LiveUpdate\Downloads\automatic$20liveupdate_3.3.0.96_english_livetri.zip" HR: 0x802A0026
11/11/2010, 11:51:16 GMT -> HR 0x802A0026 DECODE: E_HTTP_NOT_FOUND
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0       , Num Successful: 0
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantecliveupdate.com/symevent64x86$20installer_12.8_symalllanguages_livetri.zip", Estimated Size: 0, Destination Folder: "C:\ProgramData\Symantec\LiveUpdate\Downloads"
11/11/2010, 11:51:16 GMT -> HttpSendRequest (status 404): Request failed - File does not exist on the server.
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantecliveupdate.com/symevent64x86$20installer_12.8_symalllanguages_livetri.zip", Full Download Path: "C:\ProgramData\Symantec\LiveUpdate\Downloads\symevent64x86$20installer_12.8_symalllanguages_livetri.zip" HR: 0x802A0026
11/11/2010, 11:51:16 GMT -> HR 0x802A0026 DECODE: E_HTTP_NOT_FOUND
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0       , Num Successful: 0
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantecliveupdate.com/ms$20light_5.0_symalllanguages_livetri.zip", Estimated Size: 0, Destination Folder: "C:\ProgramData\Symantec\LiveUpdate\Downloads"
11/11/2010, 11:51:16 GMT -> HttpSendRequest (status 404): Request failed - File does not exist on the server.
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantecliveupdate.com/ms$20light_5.0_symalllanguages_livetri.zip", Full Download Path: "C:\ProgramData\Symantec\LiveUpdate\Downloads\ms$20light_5.0_symalllanguages_livetri.zip" HR: 0x802A0026
11/11/2010, 11:51:16 GMT -> HR 0x802A0026 DECODE: E_HTTP_NOT_FOUND
11/11/2010, 11:51:16 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0       , Num Successful: 0
11/11/2010, 11:51:16 GMT -> Progress Update: TRIFILE_DOWNLOAD_END: Number of TRI files: "0"

Clairement, les logs montrent l’erreur 404 (ressources non-accessibles).

Je n'ai pas d'Internet Explorer 9 beta sur ma machine mais le problème semble être similaire. Alors, d'où vient-il?

Surtout sur Windows 7 64bit, ce type de problème est souvent lie à la configuration proxy reconnue par le Système d'Exploitation. LiveUpdate fait la mauvaise interprétation du proxy étant sur place, tandis que cela n’est pas vraiment le cas (la connexion web se fait directement). Ce problème peut arriver même si LiveUpdate n’est pas configuré expressivement pour utiliser le proxy. Dans cette situation il faut forcer Internet Explorer (dont LiveUpdate utilise les ressources pour se connecter à l’internet et interpréter le type de connexion) à ne pas « utiliser » le proxy afin de ne pas tromper LU que ce dernier est présent.

Comment régler ce problème?

Il est déjà prouve que la présence d’Internet Explorer 9 beta met la configuration de LiveUpdate en conflit avec ce navigateur. Par contre, si IE9 n'est pas présent sur le système, il faut appliquer la solution suivante:

  1. Désinstallation du client SEP
  2. Téléchargement et installation de PsExec  a partir du site suivant : http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx
  3. Ouvrir la ligne de commande et taper la commande suivant e :

psexec -i -s "C:\Program Files\Internet Explorer\iexplore.exe"

  1. Redémarrage du PC et réinstallation de client SEP

J’espere que cela vous a apporté la reponse aux questions directement liés à ce probleme specifique. Si cela n’est pas le cas, n’hesitez surtout pas à me contacter sur Symantec Connect afin de poser les questions supplementaires.