Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Archiving and eDiscovery Community Blog

Setting up OWA with Enterprise Vault - A lesson learned

Created: 27 Sep 2013 • Updated: 29 May 2014
Rob.Wilcox's picture
0 0 Votes
Login to vote
I've setup Enterprise Vault with Outlook Web App on Exchange 2010 many, many times before.  However, it has been quite some time since I did it last, and I hit a problem.  The problem I had was that when I was running:
 
cscript owauser.wsf /domain....etc
 
It was coming back with:
 
WScript version: 5.8
Configuring for Exchange 2003/2007
Running as: ROWIEV\vaultadmin
User name: vaultadmin
User domain: rowiev.local
Assigned user right: SeNetworkLogonRight
Assigned user right: SeInteractiveLogonRight
Assigned user right: SeBatchLogonRight
Assigned user right: SeChangeNotifyPrivilege
ERROR: Failed to update IP address restrictions. Check that Feature Delegation for 'IPv4 Address and Domain Restrictions' is set to 'Read/Write'
 
Now, tried as I might I couldn't find out how to do this so that the script would run to completion.  In the end I found it.  What you have to do is click on the MACHINE itself in IIS Manager:
 
owa - 2013-09-05_21h50_13.png
 
Then you can click on FEATURE DELEGATION, which is just down at the bottom of the screenshot above.  
 
You can scroll down to the section for IP restrictions, and set it to read/write:
 
owa - 2013-09-05_21h50_25.png
 
And hey presto - problem solved, script runs perfectly.