Screencasts - Hilfsvideos
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EVSVR Results File ("ArchiveFolder records absent" and "Root without ArchiveFolder")

Created: 12 Feb. 2013 • Aktualisiert: 23 Juli 2013 | 7 Kommentare
Dieses Problem wurde gelöst. Siehe Lösung.
Hi,
I'd like some help understanding the EVSVR results file.
We recently had a SQL failure and needed to restore one of our Vault Store databases. Running an EVSVR Verify has multiple entries and summary as below.
What does this mean?
Thanks,
EC
 
2013-02-12 08:08:57        Missing Directory ArchiveFolder record:
2013-02-12 08:08:57          ArchiveFolder EntryId: 1B281BAE85F809D4088AF219D40188CF21110000xxxx-em1-01, Items: 5
2013-02-12 08:08:57          Archive EntryId:       1CCEF2C5376581F4EB92DD6C378DA4BAC1110000xxxx-em1-01
2013-02-12 08:08:57  
2013-02-12 08:08:58        Vault records processed:        405961
2013-02-12 08:08:58  
2013-02-12 08:08:58        ArchiveFolder records found:    401340
2013-02-12 08:08:58        ArchiveFolder records absent:   3159
2013-02-12 08:08:58        ArchiveFolder records missing:  0
2013-02-12 08:08:58            Including Archive records:  2
2013-02-12 08:08:58            With Items:                 203
2013-02-12 08:08:58            Without Items:              279
2013-02-12 08:08:58  
2013-02-12 08:08:58        Incorrect ArchiveFolder records:
2013-02-12 08:08:58            Root without ArchiveFolder: 980
2013-02-12 08:08:58            Type is Archive:            0
2013-02-12 08:08:58            NULL ContainerRootIdentity: 0

Kommentare KommentareZum neuesten Kommentar

das Bild der Pradeep_Papnais

As far as I know this problem comes if there is a mismatch of entries where items exist in the Vault Store Database, but the associated Archive, ArchiveFolder, or Root entry does not exist in the EnterpriseVaultDirectory database. This problem is fixed in 9.0 SP4 & 10.0 SP1 as per TN http://www.symantec.com/docs/TECH158169.

LÖSUNG
das Bild der GabeVs

I think this TN applies when you restore the EnterpriseVault directory database, not the Vault Store database. If I am reading correctly, the Vault Store database was restored:

A mismatch of SQL databases can occur when an EnterpriseVault directory database is restored  to a date prior to the latest update of an associated Vault Store database.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

das Bild der GabeVs

Did you restore just the databases in SQL? What about the storage? If you just restored the databases, then you have a data mismatch between the storage and the databases. EVSVR errors are expected. Thus, you need to run EVSVR in repair mode to recreate all the missing entries on the database.

If this is the case, I strongly recommend you to open a ticket with EV support to assist you with the process, since it's very important to analyze the EVSVR verify log to determine what repair option do you need.

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

LÖSUNG
das Bild der EC at TWs

Thank you both for looking into this.

Yes it was a restore of the Directory and VaultStore databases but the data remained.

I did open a ticket and am still working with support on the EVSVR jobs.

Thanks again.

das Bild der EV_Ajays

Thanks for information.

Just quick question : What is version of Enterprise Vault ?

Thanks,

Ajay

das Bild der EC at TWs

It was 9.0.2 but updated to 9.0.4 for the better EVSVR performance amongst other things.

das Bild der EV_Ajays

Hi,

I also check the Etrack and found need to run the EVSVR in repair mode to recreate missing entries in database As per GabeV.

Thanks,

Ajay