Screencasts - Hilfsvideos

Linux SAN media server performances issue --- Low speed

Created: 10 Dez. 2012 • Aktualisiert: 30 Jan. 2013 | 4 Kommentare
das Bild der rajeshthinks
Dieses Problem wurde gelöst. Siehe Lösung.

Greeting to all ...

I have two SAN media server which we recently build , We did certain test and from SAN media server A we are getting speed of 70 -100 MB/s , where as from SAN media server B we get max thoughput of 20 -30 MB/s .

-----Zoning are perfect

Cheer,

Rajesh Kumar

Kommentare KommentareZum neuesten Kommentar

das Bild der Mariannes

Start with troubleshooting outside of NBU. 

1. Test read speed from disk using bpbkar test:
Increase logging level to 1
Create /usr/openv/netbackup/logs/bpbkar folder
Run: /usr/openv/netbackup/bin/bpbkar -nocont -dt 0 -nofileinfo -nokeepalives <filesystem> > /dev/null  
Check results in bpbkar log

If read performannce is good, test write speed to tape:

2. Load a scratch/blank tape in a drive.
Use tar or cpio to write backup to drive.
Note time taken to write backup.

If both methods above shows good performance, then tune NBU buffers.
Create these 2 files: 

/usr/openv/netbackup/db/config/SIZE_DATA_BUFFERS 
add a value of 
262144

/usr/openv/netbackup/db/config/NUMBER_DATA_BUFFERS 
add a value of 32 (can be more if server resources are sufficient)

Ensure bptm log folder exists to verify effect of buffer settings.
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

LÖSUNG
das Bild der Yasuhisa Ishikawas

GEN_DATA directive is pretty nice to isolate performance issue. You can measure performance between media server and storage unit in NetBackup. No need to mount tape manually.

http://www.symantec.com/docs/TECH75213

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

das Bild der rajeshthinks

I Just change the Data_buffer_size from 128 to 256 and Now i see a fair speed its writing the data.

Hope this resolve the issue , Also the backup use to take 4 days to complete Now its taking just 2 days..

so think the next step would be changing it o 512.

any suggestion are Appriciated .

cheer,

Rajesh Kumar

das Bild der Mariannes

See my earlier post on 9 December: https://www-secure.symantec.com/connect/forums/linux-san-media-server-performances-issue-low-speed#comment-8069761

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links