Screencasts - Hilfsvideos

LUA download shedule task automatically doesn't start

Created: 29 Jan. 2013 • Aktualisiert: 29 Jan. 2013 | 15 Kommentare

Hi!

I created the job for downloading, but it doesn't start according to the schedule. I tried different options of start. In case of start manually - everything works well.

LUA v.2.3.2.99

Kategorien für Diskussion:

Kommentare KommentareZum neuesten Kommentar

das Bild der Mick2009s

Hi Ray,

Odd- that looks about right, from a first glance.  Are there any entries about the DownlSEP12 task in the LUA Event Viewer?

Also: have you tried setting it to run daily at a fixed time?  Does that work?

With thanks and best regards,

Mick

das Bild der SebastianZs

Does the download starts if you change the schedule for "daily" or "once" and a specified time?

das Bild der RayWagners

In LUA Event Viewer there are no records while the job shall start automatically. There are only records when I launch it manually.
I tried to change start settings, doesn't help...

das Bild der Mick2009s

If that does not work, you may wish to generate a luadebuginfo.zip file and post it to this thread. 

Gathering logs and troubleshooting data from LiveUpdate Administrator 2.x
http://www.symantec.com/docs/TECH92654

The logs in there usually require advanced knowledge to read, but there may be some admins her ein the forum who can take a quick looka nd spot the cause.
 

With thanks and best regards,

Mick

das Bild der RayWagners

Event Log and lua-application - there are no error messages..

ZubehörGröße
luadebuginfo.zip 3.11 MB
das Bild der Ajit Jhas

Thank you for uploading the luadebug log and i can see there is a DEBUG schedule.EditScheduleForm  - 1 errors found.

just give some time to analyse.

Regard's

Ajit Jha

Technical Consultant

ASC & STS

das Bild der Ajit Jhas

Yes, Mike is right. To go in depth analysis of LUA troubleshooting, we need the luadebuglog file. Please collect it and upload it.

Regard's

Ajit Jha

Technical Consultant

ASC & STS

das Bild der SebastianZs

The log shows many 404 errors:

2013-01-29 09:10:09,803 [pool-121-thread-1] ERROR rcl.HttpHelper  - Http Error Msg : HTTP/1.1 404 Not Found
2013-01-29 09:10:09,803 [pool-121-thread-1] ERROR rcl.HttpHelper  - Fatal transport error in download: 404: could not find file to download - http://liveupdate.symantecliveupdate.com:80/sepc$20iron$20settings$20v12.1_microdefsb.may_symalllanguages_livetri.zip on: ConnectionInfo ( com.symantec.lua.mdl.server.ConnectionInfo@44be94    id = 1    hostName = liveupdate.symantecliveupdate.com    hostPort = 80    protocol = HTTP

...seems the connection goes over proxy...not necesarily meaning a problem if your manual downloads are still working

- can you try to update "Update Symantec Product Catalog" from LUA GUI?

- in the download schedule can you reset the timer start date to a future date (some later time today)?

das Bild der RayWagners

In case of manual start all jobs of loading are successful.

Update "Update Symantec Product Catalog" - in Event Log - 'Successfully refreshed Symantec Product Catalog'

...- in the download schedule can you reset the timer start date to a future date (some later time today)? - Yes.

das Bild der Mick2009s

Hi Rob,

Here is the most unusual thing I am seeing in a quick ten-minute examination of those logs: there are 19 of these schedule-related errors....

2013-01-29 14:55:59,835 [http-apr-0.0.0.0-7070-exec-43] ERROR cleanCLU.CleanUpThreadPool  - Exception occured while adding a schedule: org.quartz.JobPersistenceException: Couldn't retrieve job because the BLOB couldn't be deserialized: invalid stream header: BB656430 [See nested exception: java.io.StreamCorruptedException: invalid stream header: BB656430]
 

That might be caused by one or two things.  The simplest fix I recommend is to change this server's time zone from Russian Standard Time to GMT, then restart the two LUA services (LUA PostgreSQL and LUA Apache Tomcat). 

If that does not correct the problem, delete this scheduled download job and recreate it. 

Please update this thread with the results!  &: )

With thanks and best regards,

Mick

das Bild der RayWagners

1. I changed this server's time zone from Russian Standard Time to GMT

2. Restarted the two LUA services.

3. I deleted and recreated downloading task.

..Jobs still don't start automatically (((

I switched regional settings to US - doesn't work..

I attached Troubleshoot log after changes.

ZubehörGröße
luadebuginfo_2.zip 3.59 MB
das Bild der Mick2009s

Hi Ray,

You're probably best off opening a case with Technical Support and having the trauied engineers there look into the matter officially.  What you are seeing is not normal: scheduled tasks should run consistently and reliably. 

All the best!!

Mick  

With thanks and best regards,

Mick

das Bild der RayWagners

I made search in Google on a line "Couldn't retrieve job because the BLOB couldn't be deserialized: invalid stream header: BB656430" Found article - http://z0ltan.wordpress.com/2012/01/04/serializati... I reinstalled OS and LUA and everything earned.

das Bild der Mick2009s

Thanks for the update, Ray!  A very odd issue. It's working on schedule now, I take it?

With thanks and best regards,

Mick