Screencasts - Hilfsvideos

NS6.0 - Unknown or unspecified error opening packages

Created: 21 März 2012 • Aktualisiert: 22 März 2012 | 1 Kommentar
Dieses Problem wurde gelöst. Siehe Lösung.

Hi folks, running NS6.0.6074 (SP3 + R13) , and when I try to open certain software packages on one of my NS servers (some packages, not others, with no apparent rhyme or reason), I get a message stating:

The following error occurred on the page 'packages2.aspx':

Unknown or unspecified error

 In the Log Viewer, I see the following 5 errors. Has anyone got any ideas for me? Looking in the knowledge base, there are only two instances of any errors remotely related to packages2.aspx, and neither fit the bill. I have tried deleting the packages and recreating, but no dice. Any help would be appreciated. Thanks everyone,

 "3/21/2012 6:38:49 PM","Failed in Thread was being aborted.:    at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetInstallers(String path)
   at Altiris.NS.SWDWin32.UI.Controls.ctrlPackageSourceLocationPurgingOption.LoadInstaller()","LoadInstaller","w3wp.exe","5920"

"3/21/2012 6:38:49 PM","Failed in Thread was being aborted.:    at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.FindFiles(String path, String fileExtension, ArrayList MsiFileArray, SWMItemType instApp)
   at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetInstallers(String path)","GetInstallers","w3wp.exe","5920"

"3/21/2012 6:38:49 PM","Failed in Thread was being aborted.:    at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetAppInstallerDetails(String AppInstFileName, SWMItemType instApp)
   at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.ShowFileData(FileInfo[] files, String extension, ArrayList& MsiFileArray, SWMItemType instApp)","ShowFileData","w3wp.exe","5920"

"3/21/2012 6:38:49 PM","Failed in Thread was being aborted.:    at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetMsiFileProperties(String msiFileName)
   at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetAppInstallerDetails(String AppInstFileName, SWMItemType instApp)","GetAppInstallerDetails","w3wp.exe","5920"

"3/21/2012 6:38:49 PM","Failed in Thread was being aborted.:    at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.MsiOpenDatabase(StringBuilder msipath, Int32 databasepersist, IntPtr& msihandle)
   at Altiris.NS.SWDWin32.SoftwareManagement.InstallerAnalyser.GetMsiFileProperties(String msiFileName)","GetMsiFileProperties","w3wp.exe","5920"

P.S. - Where is the best place to put NS problems, so that they have the most visibility: this forum, or the Symantec Management Platform (Notification Server) forum? Thanks again!

Kommentare 1 CommentZum neuesten Kommentar

das Bild der DustinWs

http://www.symantec.com/docs/TECH41325  seems to describe my problem very well. Seems I was a bit too preoccupied with the "packages2.aspx" error message I got. I'm going to try the solution laid out here.

EDIT: This KB article did indeed fix my problem. The packages still take forrreeeeevvvveerrrrrr to open, but at least they open instead of timing out. Looking at the packages that fail, I see that they are all rather large (at least 300MB), and more importantly, I think, they all have a rather high file count. But, success is success! I'll take it.

Thanks :)

LÖSUNG