Ayuda de vídeo de Screencast

After Upgrade to v6: monitor:Blockmountpointaccess not configured

Created: 05 Sept 2012 • Updated: 11 Sept 2012 | 3 comments
Se ha solucionado este problema. Vea la solución.

Hi there

We upgraded our Test single Node cluster to the version 6 with cp2.

After the installation and reboot all of the mountv resource are in a failed state.

in the mountv_a.txt logfile i found this line: monitor:Blockmountpointaccess not configured

Any suggestions how to fix that?
Thanks

Comentarios ComentariosIr al último comentario

el cuadro de los Sigi

the problem with the mounting appears right after the update with the cumulative hotfix update 2 (cp2) on v6.0

Everything is working fine after the upgrade from 5.1 sp2 to v6.0

2012/09/06 14:53:10 VCS DBG_21 V-16-50-0 MountV:LOGS:monitor:*** Start of debug information dump for troubleshooting ***
    LibLogger.cpp:VLibThreadLogQueue::Dump[206]
2012/09/06 14:53:10 VCS DBG_21 V-16-50-0 MountV:SYSTEMDB:monitor:vxVolume open failed
    MountV.c:MountV_monitor[301]
2012/09/06 14:53:10 VCS DBG_21 V-16-50-0 MountV:LOGS:monitor:GetDgVolumeGuid failed. Error: 33
    LibVMObj.cpp:VLibVMObj::GetVolGUID[1195]
2012/09/06 14:53:10 VCS DBG_21 V-16-50-0 MountV:SYSTEMDB:monitor:*** End of debug information dump for troubleshooting ***

el cuadro de los Tony T

Hi Sigi

Look at the types.cf located at C:\Program Files\Veritas\Cluster Server\conf\config, the MountV type is most probably missing the "BlockMountPointAccess" attribute.

Issue a hastop -all -force 

Take a backup of the existing types.cf file.

Manually add or modify the MountV resources attributes with "boolean BlockMountPointAccess = 0" to the types.cf and save the file.

Should end up looking like this:

"type MountV (

                static i18nstr ArgList[] = { MountPath, VolumeName, "VMDGResName:DiskGroupName", ForceUnmount, ListApplications, AutoFSClean, "VMDGResName:DGGuid", PurgeStaleMountPoints, CheckFSAccess, BlockMountPointAccess }

                i18nstr MountPath

                str VolumeName

                str VMDGResName

                str ForceUnmount = READ_ONLY

                boolean ListApplications = 1

                boolean AutoFSClean = 1

                str MountResName

                boolean PurgeStaleMountPoints = 1

                boolean CheckFSAccess = 0

                boolean BlockMountPointAccess = 0

)"

Restart HAD on all nodes using hastart -all.

Resources should now probe.

SOLUCIÓN