Ayuda de vídeo de Screencast

Error during attempt to delete directory path.

Created: 14 Marzo 2012 • Updated: 15 Marzo 2012 | 6 comments
el cuadro de los zzpack
Se ha solucionado este problema. Vea la solución.

I have added a .xml under the path:
C:\Users\Administrator\AppData\Roaming\...

So, I can see the file under the (Writeable) area, in my virtual layer. Now I want to create a
new reset point, and Copy current users settings to default user settings area.

When creating a new reset point, I get the following error message:

"Error during attempt to delete directory path."

Anyone that knows more about this errror?

Comentarios ComentariosIr al último comentario

el cuadro de los EdT

Apart from the fact that the Administrator profile is not the default user, the issue you are facing is a lack of permissions. Since user accounts, including those with administrative privileges, run with limited rights unless elevated (or unless you switch UAC off), any user not called "Administrator" has no write access to the Administrator profile. (Or have I misunderstood your posting?)

Workspace virtualisation does not offer any way of bypassing user permissions - it provides the same permissions as you would have if the app was not virtualised.

The best way to get these issues implemented before you create your final layer for use elsewhere, is either on an XP platform, or on a machine with UAC turned off. Then you can implement changes that may otherwise be blocked on Win 7 with UAC turned on.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

el cuadro de los zzpack

EdT:

UAC was turned off, since I´m doing different re-packaging and virtualization tasks
on my virtual machine.

I´m too thinking about what permission issue this is all about. Do you know if and 
how I can log what is happening during creation of the virtual layer?

The error message "Error during attempt to delete directory path" is annoyingly
generic. As most error messages are...

el cuadro de los EdT

I would recommend running Procmon either in the base or the layer, depending on where the error is originating (or both if unsure). Then at least you can find out where the access reports insufficient rights.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

el cuadro de los zzpack

Now I fixed it. I just cleaned out some temp files that I forgot to remove from the
writeable area erlier. Then it worked fine to create a new reset point.
 

SOLUCIÓN
el cuadro de los EdT

I reckon you won't make that mistake again....!!

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

el cuadro de los zzpack

Well, everyone does make mistakes. It´s just a matter of fixing them.