Ayuda de vídeo de Screencast

I get Warning: PGPsdk running in local mode when trying to sign & encrypt the file

Created: 05 Nov 2012 | 4 comments

Hi All,

We use PGP Command Line 9.8 build 28 version. (Windows 2003 R2 Ent. SP2)

There is automated script which signs and encrypts the file. When I try to process several files sequencially the first one is signed and encrypted without any errors but the second and following ones fail.

What the script does:

1. Since for signing is used out private key we first cache the passphrase (for 10 seconds) used for private key by running the following command.

pgp.exe --cache-passphrase <Our_Key_pair_ID> --passphrase <bla-bla-bla> --passphrase-cache --passphrase-cache-timeout 10

2. Then we try to sign and encrypt the file:

pgp.exe --encrypt <file_to_encrypt> --sign --signer <Our_Key_pair_ID> -r <Customer_Pub_Key_ID> --output <encrypted_filename> --overwrite remove

But for second file I get something like this:

Warning: PGPsdk running in local mode.
<Our_Key_pair_ID>:encrypt (3011:invalid passphrase specified)

so pgp exits with %ERRORLEVEL%=162

My question is why it switches in local mode? (in docs I found that in local mode password caching doesn't work...)

Please note PGP_LOCAL_MODE variable is not defined in our environment.

The PGP is licensed and we have no issues when just encrypting/decritping the files. The problem appears when we try to sign the file in addition to encryption.

Constantin,

Many Thanks

Comentarios ComentariosIr al último comentario

el cuadro de los dfinkelstein

Likely, it is having a problem contacting the PGP SDK service.  This service is responsible for passphrase caching.  Please check that the service is still running properly; it's possible that it has stopped.

There have been a number of fixes to PGP Command Line over the years to address issues with the SDK service (in fact, we don't even use the service anymore with the latest versions).

--------

David Finkelstein

Symantec R&D

el cuadro de los Constantin

Yes, the service goes down and I have to start it again manually.

So I understand the option is to upgrade to latest version.

Does anyone know if I can use the existing license key (PGP Command Line 9.8 build 28 version) with the latest version?

Thanks

el cuadro de los dfinkelstein

You will get a new license number when you upgrade to the newer version.

--------

David Finkelstein

Symantec R&D