Ayuda de vídeo de Screencast
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

License count does not match filter count

Created: 15 Enero 2014 • Updated: 21 Mayo 2014 | 4 comments
el cuadro de los GarethNZ
Se ha solucionado este problema. Vea la solución.

Hi, are currently can not run tasks, we get the error "No Licensed computers or targets with licensed computers were assigned". Home\Notification Portal Management\First Time Setup shows "Altiris Software Management Solution 1600/1600", but if I check the filter "All computers with installed Software Management Plug-in" the count is only 1534. Any clues why there might be such a difference? We do have custom asset status (for stock), PCs with the custom asset status do not show in the filter results (same as retired or disposed), maybe the actual license count is still counting them, is there a way to check? Thanks.

Operating Systems:

Comentarios ComentariosIr al último comentario

el cuadro de los SK

I believe that that web part uses the following query:

select  vp.[Name] as [Product Name],
    (case
        when la.[PolicyType] = 'Server' and la.[TotalCount] <> 0 then 1
        when la.[PolicyType] = 'Server' and la.[TotalCount] = 0 then 0
        else la.[LicensingPolicyInUseCount]
    end) as [Licensing Usage],
    la.[LicenseGuidInUse] as [Guid],   
    (case
          when la.[PolicyType] = 'Server' and la.[TotalCount] <> 0 then '1'
          when la.[PolicyType] = 'Server' and la.[TotalCount] = 0 then '0'
          when la.[TotalCount] = -1 then 'Unlimited'    
          else cast(la.[TotalCount] as char(20))   
      end) as [License Total]   
  from vProduct vp     
      inner join LicenseStatus la
         on la.[ProductGuid] = vp.[Guid]     
          and la.[TotalCount] <> -2  
  order by vp.[Name],
    la.[LicensingPolicyInUseCount],
    [License Total]

If you look at a computer that has a custom asset status in the vComputer view, does it have a 0 or a 1 in the IsManaged column?

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

el cuadro de los SK

This may be of use to you: 

"Altiris Licensing - Technical FAQ" (http://www.symantec.com/docs/HOWTO1201)

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SOLUCIÓN
el cuadro de los GarethNZ

Thanks SK, I've read "License recovery—License recovery is dependent on deleting the computer record. For Software Management Solution starting from version 7.5, a license is also released after setting the computer status to any value other than Active" that expains our issue, but is very disappointing, we won't be upgrading to 7.5 because we rely on Resovery Solution, and we are deploying Windows 8.1 devices soon so we've had to put SCCM in anyway to be able to fully manage them (pcAnywhere doesn't support 8.1), so I can't see us updating to 7.5.

el cuadro de los SK

Always happy to help.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.