Ayuda de vídeo de Screencast
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Migrating Backup Exec 2010 to 2012 to a new Server/Hardware

Created: 05 Febrero 2013 • Updated: 17 Marzo 2013 | 8 comments
Se ha solucionado este problema. Vea la solución.

Hello,

I'm in the process to migrate our Backup Server from Symantec 2010 to the latest version 2012 to a new server/hardware with different server name.

What are the steps to ensure all the backup logs/historical reports are migrated to the new server?

Is it better to go with fresh installation on the newer server and then I migrate the DB from old to the New Server?

Or first

  1. Install SQL on the new Server
  2. Migrate the DB from old Server
  3. Attach the DB to the new Server
  4. Install Symantec Exec 2012  and point it to the old DB

Is it possible to install it on different server name and latter on I can change the name back to match the old server?

Appreciate your tips/suggestions.

Thanks,

Comentarios ComentariosIr al último comentario

el cuadro de los Gurvinder Rait

You can take a backup of data and catalog folder before attempting the upgrade.

Please go through the articles on this Link first (Important) - http://www.symantec.com/theme.jsp?themeid=backup-exec-2012

el cuadro de los VJware

Use this KB for moving Backup Exec to a different machine & different name ~ http://www.symantec.com/docs/TECH67296

Post the migration, upgrade to Backup Exec 2012.. Here is a link which outlines the upgrade - http://www.symantec.com/tv/products/details.jsp?vi...

el cuadro de los pkh

BE 2012 is quite different from BE 2010.  You would find that most of your jobs and media would be changed.

Are you using dedup?  If yes, then you may have no choice but to upgrade.

If not, then you might want to consider a fresh install and re-create your jobs.

You can migrate your catalogs by copying the contents of your old catalogs to the new catalog directory and restart your BE services.

el cuadro de los CraigV

...what nobody has mentioned is upgrading the current server to BE 2012 FIRST. This means no having to content with possible issues between database mismatches, and hoping bemig moves everything across.

You're not moving the same version...you're moving between versions.

I would grab copies of the Data/Catalogs folders; then upgrade to BE 2012 w/SP1a. Install BE 2012 w/SP1a on the new server, and then follow the TN below (no having to use ossql etc. to get things moved across):

http://www.symantec.com/business/support/index?pag...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUCIÓN
el cuadro de los habibalby

Hi,

Having a problem getting the Schema upgrade;

C:\Program Files\Symantec\Backup Exec>bemig
Executing migration of BEWS data.
SetRange: from=0 to=0
Status Message: DriverConnect:DRIVER=SQL Server;SERVER=MUBBACK001\BkupExec;DA
ASE=BEDB;App=BEWS PVLUPGRADE
Status Message:
Status Message: VersionName   = ADAMM 14.0,  VersionNumber = 14.0000000000
Status Message: AdammUpgradeView::Initialize() = 0
Status Message: JobMigration Internal Registry Key [Software\Symantec\Backup
c For Windows\Backup Exec\Server\JobMigration Internal]=0
Status Message:
Status Message:
Status Message: VersionName   = ADAMM 14.0,  VersionNumber = 14.0000000000
Status Message: VersionName   = ADAMM 14.0,  VersionNumber = 14.0000000000
Status Message:
Status Message:
Status Message: UpgMachineName=MUBBACK001
Status Message: UpgVirtualName= UpgMachineName=MUBBACK001
Status Message: UpgSQLInstance=MUBBACK001\BkupExec
Status Message: Unable to open or query registry key Upgrade Version.
Status Message: Fail to GetPreviousVersion
Status Message: origial build number 0
Status Message: Job Migration Success
Status Message: Job Migration Success
Status Message: Starting the upgrade of the catalog database
Status Message:
CleanupDBForReIndexing: Cleaning up database for ReIndexing.

Status Message:
Catalog Schema 13.0

Status Message:
CleanupDBForReIndexing: SchemaUpgrade failed.

Upgrade state set to 805306369

I have used the TECHNOTE 50537 http://www.symantec.com/business/support/index?pag... to get the Registry updated to the latest version, I got the services are not coming up; then I used the BEUTILITY to move the DB from DeskStop; but also the services failed to start; Reparing the installation; would fail becuase the DB files are not matched with the same SQL version;

Copy data from specified database files.
Stopping Services
Stopping services for server:MUBBACK001.
Server:MUBBACK001, Service:BackupExecAgentBrowser stopped successfully or was not running.
Server:MUBBACK001, Service:BackupExecJobEngine stopped successfully or was not running.
Server:MUBBACK001, Service:BackupExecManagementService stopped successfully or was not running.
Server:MUBBACK001, Service:BackupExecRPCService stopped successfully or was not running.
Server:MUBBACK001, Service:BackupExecDeviceMediaService stopped successfully or was not running.
Server:MUBBACK001, Service:BackupExecAgentAccelerator stopped successfully or was not running.
Stopping services for server MUBBACK001 completed.
Operation to stop services completed.
Stopping SQL service on server: MUBBACK001 : MSSQL$BKUPEXEC
Starting SQL service on server: MUBBACK001 : MSSQL$BKUPEXEC
Failed to detach database BEDB from server MUBBACK001.
Stopping SQL service on server: MUBBACK001 : MSSQL$BKUPEXEC
Starting SQL service on server: MUBBACK001 : MSSQL$BKUPEXEC
Attaching database BEDB to server MUBBACK001.
Starting services for server:MUBBACK001.
Server:MUBBACK001, Service:BackupExecAgentAccelerator started successfully.
Server:MUBBACK001, Service:BackupExecDeviceMediaService started successfully.
Server:MUBBACK001, Service:BackupExecRPCService failed to start.
Server:MUBBACK001, Service:BackupExecManagementService failed to start.
Error: (1068) - The dependency service or group failed to start.

Server:MUBBACK001, Service:BackupExecJobEngine failed to start.
Error: (1068) - The dependency service or group failed to start.

Server:MUBBACK001, Service:BackupExecAgentBrowser failed to start.
Error: (1068) - The dependency service or group failed to start.

Starting services for server MUBBACK001 completed.
Error: Starting services for a list of servers failed, see prior errors.
Operation to change location of Backup Exec database to SQL Server instance MUBBACK001 ended with errors.
 

Any help?????

Thanks,

el cuadro de los habibalby

It seems i have to do what CraigV has mentioned, I have to upgrade the Current Version Backup Exec 2010 on the old server to Backup Exec 2012 then I have to move it to the new server/hardware.

el cuadro de los CraigV

...it will work, no hassles. And it is easy to do! Don't make life difficult by doing things manually...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

el cuadro de los habibalby

I have uninstalled from the new server, first will upgrade the old server with the latest version of Backup Exec 2012, run live update and do fresh installation on the new server, then will do the migration/data movement process.

Thanks,