Ayuda de vídeo de Screencast

re-license with a "--force"

Created: 29 Nov 2012 • Updated: 05 DEC 2012 | 10 comments
Se ha solucionado este problema. Vea la solución.

When I try to issue following command:

command = "pgp --license-authorize --license-name ""myName"" --license-organization ""myOrganization"" --license-number Dxxx-xxxx-xxxx-xxxxx-xxxxx-xxx --license-email mySelf@mycompany.com --force"

I get following messages:

pgp: license authorize (2706: PGP Command Line already has a license)

license authorize (3104: could not read file, no such file or directory)

I thought I would be able to re-license with a "--force", but still not working. Can anyone please help?

Comentarios ComentariosIr al último comentario

el cuadro de los Tom Mc

Please see this prior thread: https://www-secure.symantec.com/connect/forums/pgm...

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

el cuadro de los HAN_LNT

I tried using as per suggestied.. but it is still not working.

command = "pgp "--license-authorize" --license-name ""myName"" --license-organization ""myOrganization"" --license-number Dxxx-xxxx-xxxx-xxxxx-xxxxx-xxx --license-email mySelf@mycompany.com --force"

el cuadro de los dfinkelstein

"--force" is used to re-license PGP Command Line if it already has a license.

The error

license authorize (3104:could not read file, No such file or directory)

is, I believe, because the invocation of PGP Command Line believes you are trying to provide a license authorization file, but the file cannot be found and opened.  Exactly why, is likely due to some improper quoting of your command line arguments.

Just in front of the error message you have given ("license authorize (3104: could not read file, no such file or directory)") should be some other text, followed by a colon ':'.  That text is the name of the file that PGP Command Line is trying to open as the license authorization file.

--------

David Finkelstein

Symantec R&D

el cuadro de los HAN_LNT

I ran this following command  and still got error. File license-auth.txt is present in specific location. But still it is showing this error.

Command:

pgp --license-authorize --license-name "xxxxxxx" --license-organization "xxxxx" --license-number "xxxxxxxxxxxxx" license-auth.txt --license-email "xxxxxx@xxxxx.com" --force

Error:

pgp:license authorize (2706:PGP Command Line already has a license)

license-auth.txt:license authorize (3104:could not read file, No such file or di

rectory)

el cuadro de los dfinkelstein

There is still some problem finding this file.

By "specified location" do you mean that it is in the current working directory of where you are running "pgp --license-authorize"?  So if you do "ls license-auth.txt" (or "dir license-auth.txt") just prior to running "pgp --license-authorize" it shows the file is there?

--------

David Finkelstein

Symantec R&D

el cuadro de los HAN_LNT

Yes, It shows the file.

D:\PGP_Home>dir license-auth.txt

Volume in drive D is APPs

Volume Serial Number is XXXX-XXXX

 Directory of D:\PGP_Home

 07/28/2008  09:49 AM               166 license-auth.txt

               1 File(s)            166 bytes

el cuadro de los dfinkelstein

To confirm, you are running this command from D:\PGP_Home ?

Could you please post the entire invocation you are using?  (Though 'X' out the license information and any other confidential information you have, but keep any spaces that may appear in the values.)

Thanks.

--------

David Finkelstein

Symantec R&D

el cuadro de los HAN_LNT

I ran the command from D:\PGP_Home and i was able to authorise the license. Thanks.

But when i tried to import a vendor's public key, it showed me error as invalid license.  

Command:

D:\PGP_Home>pgp --import "D:\PGP Corporation\vendorkey.asc" --home-dir D:\PGP_Home

pgp:import key (2712:invalid license)

el cuadro de los dfinkelstein

PGP Command Line keeps information about the license status in the preferences file.  This file is found in the "home directory".  If you did not license PGP Command Line using the "--home-dir" option, then the license information was placed in the preferences file in your "default" home directory, and now that you are specifying "--home-dir" it cannot be found.

One quick solution is to simply re-license again, but this time specify "--home-dir".

The latest version of PGP Command Line does try to store the license information in a system-wide preferences file (so that PGP Command Line appears to be licenced for all users).  But if you did run as an administrator when you authorized the license, it is likely that the system-wide preferences file could not be created.

--------

David Finkelstein

Symantec R&D

SOLUCIÓN
el cuadro de los HAN_LNT

Thanks for your help on this. I was able to import, sign and trust the key after specifying the "--home-dir" in re-license command.