Ayuda de vídeo de Screencast

SIM and SSL

Created: 29 Marzo 2013 • Updated: 05 Abril 2013 | 2 comments
Se ha solucionado este problema. Vea la solución.

I have an odd issue. Both our Production and Development SMP environments are configured to require SSL. When I install a new feature in DEV, SIM works fine and connects to the server just fine over SSL to do the installations. However, in production I always have to turn off "Require SSL" in IIS for SIM to correctly install or upgrade SMP. It always try to connect to port 80 and the HTTP site instead of the SSL site. Does SIM hold it's own configuration settings or something? When we originally installed our Production box we had to turn off SSL because of an issue with SIM messing up with a SAN cert. This was later fixed in a SIM update. However it seem SIM still thinks our Prod box isn't ussing SSL. Are there some config files or regkeys I can update to stop this?

Operating Systems:

Comentarios ComentariosIr al último comentario

el cuadro de los Abhijit Patil

Could you please share what SIM version used on Production? If you are using latest version 7.5.92 then SIM would detect IIS changes for SSL.

However please note below points if you are using older version:

Check registry path - HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\NSConfiguration

If we change this NsConfiguration settings as follows -
Change 'NSWebsiteSSL' to 'True'
Change 'NSWebSitePort' to '443' or [SSL port you have configured for website]

then refresh registry.

After these changes, we re-launched SIM and try to install another solution. It got installed successfully.

This regitry change will resolve issue and need to launch SMP console with https:\\

Thanks.

SOLUCIÓN
el cuadro de los noodleNT

Those settings were incorrect in my system I changed them to use SSL and will test it out when we put the next updates into production.