Ayuda de vídeo de Screencast
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Token parser is broken on SP2

Created: 13 Enero 2012 • Updated: 16 Febrero 2012 | 3 comments
Se ha solucionado este problema. Vea la solución.

Hi All,

I have an issue with tokens on my SMP environment with SP 2. It seems the task parser is broken so that is why my tasks which are using the tokens do not works properly. I spent a lot of time to understand there is the problem and when I run a simple command script I got very strange behavior. The tokens return an empty string. Here is a simple Script task that should return ip address but as result return an empty string:


if there is some string before token I can get expected result


>>C:\Windows\system32>REM hello

There is a short list of base componenst i am using now:     

Name Version
Altiris Client Management Suite 7.1 SP2  7.1.3
Altiris CMDB Solution 7.1 SP2 7.1.6003
Altiris Deployment Solution Complete Suite 7.1 SP1a MR1a 7.1.2320
Altiris Deployment Solution Core 7.1 SP1 MR1 7.1.2316
Altiris Inventory Solution Core 7.1 SP2 7.1.7580
Altiris Server Management Suite 7.1 SP2 7.1.3
Altiris Software Management Solution 7.1 SP2 7.1.7580
Symantec Management Platform 7.1 SP2 7.1.6778

Doe anybody know how to fix this issue?



Comentarios ComentariosIr al último comentario

el cuadro de los Alex Bizjajev

Hi Alexey,

In your post the SMP version is 7.1.6778. This is not the 7.1.SP2 (7.1.SP2 SMP version is 7.1.8280).

Also, it seems like it is not quite correct to use the REM command. "REM SOMETHING" is a comment and  if you will try to use this command in CMD window then this will return the empty line (at least this is what I see on my system).

Is it possible to replace the REM with ECHO and retry the test - will you see the same problem?

Thank you,


el cuadro de los Thomas Baird

We'll need more information or testing on your part to see what is happening.

I just ran a VBScript with the following:

    msgbox "%AGENTIPADDR%'

and it worked fine.  So I ran a command script with the following:


And it worked fine as well.  So I tried your Hello version, and it worked.

I have an ITMS install of SP2 fresh, NOT upgraded.

Help us out a bit more on this.  Thanks!

Thomas Baird
Enthusiast for making things better!


el cuadro de los Alexey-Art

Hi Thomas,

It was my fault, i used the code which has mistakes and did not allow the engine start processing the tokens properly. It seems everything  works well as expected without any problems.