Ayuda de vídeo de Screencast
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Workflow Designer Error

Created: 01 Marzo 2013 • Updated: 04 Marzo 2013 | 5 comments
el cuadro de los mariomendez83
Se ha solucionado este problema. Vea la solución.

Hello community
yesterday I installed the servicedesk solution (V 7.1 SP2), with his Workflow solution too

Now, I tried to modify a project (SD.EmailMonitor) but in the moment that the project is loading appears this error:

System.MissingMethodException: Method not found: 'Int32 LogicBase.Core.ProjectData.get_CreatedWithVersion()'.
   at LogicBase.Tool.ProjectLoading.ProjectLoader.CheckBuildNumber()
   at LogicBase.Tool.ProjectLoading.ProjectLoader.LoadProject()
   at LogicBase.Tool.Program.LaunchTool(String[] args)
   at LogicBase.Tool.ToolInitilizationHelper.Main(String[] args)

This same error appears when I try open all projects.
 

What's wrong?

Operating Systems:

Comentarios ComentariosIr al último comentario

el cuadro de los reecardo

It looks like your LogicBase.Core DLL is out of date... can you go to C:\windows\assembly, find Logicbase.Core, and read the version? Workflow 7.1 SP2 initial release should be 7.1.1460.

If that version isn't there, you should just manually upgrade WF to this version.

el cuadro de los mariomendez83

Thanks reecardo,

I'll to confirm the result

el cuadro de los mariomendez83

Thanks, the problem was that in this server was installed SD 7.5, it was uninstalled and then was installed SD7.1 SP2. I uninstalled the dlls V7.5 but, now don't open the workflow designer. I want repair this installation but now the SD installer appears this error too 

el cuadro de los reecardo

When you uninstall Workflow to downgrade, it's also a good idea to remove any remnants of our GACced DLLs from the GAC as well (if they exist). The GAC is shown when you navigate to C:\Windows\assembly in Windows Explorer. The DLLs to remove are as follows:

LogicBase.Core (and associated resources)

LogicBase.Framework (and associated resources)

LogicBase.Framework.DatabaseDrivers

Symantec.SymQ (and associated resources)

Symantec.Processmanager.WebServiceProxies

If these DLLs still exist at C:\Windows\Assembly after uninstall, stripe them, and then right click and select Uninstall.

If you've uninstalled and you can't remove them because they're "in use", you can force them to be uninstalled by deleting the appropriate folders in DOS:

C:\Windows\assembly\GAC_MSIL\LogicBase.Core

C:\Windows\assembly\GAC_MSIL\LogicBase.Core.resources

C:\Windows\assembly\GAC_MSIL\LogicBase.Framework

C:\Windows\assembly\GAC_MSIL\LogicBase.Framework.resources

C:\Windows\assembly\GAC_MSIL\LogicBase.Framework.DatabaseDrivers

C:\Windows\assembly\GAC_MSIL\Symantec.SymQ

C:\Windows\assembly\GAC_MSIL\Symantec.SymQ.resources

C:\Windows\assembly\GAC_MSIL\Symantec.ProcessManager.WebServiceProxies

After you've uninstalled from the GAC (or deleting the folders above, if you had to), delete EVERYTHING that exists at the original install location. Also remove your ProcessManager database (if you're downgrading). Then try running the installer again.

SOLUCIÓN
el cuadro de los mariomendez83

thanks reecardo.
aditionally to dll's that you posted, had some dll's "Police.Symantec.SymQ", "Police.Symantec.SymQ.resources" and "Police.LogicBase.Framework.DatabaseDrivers".

I deleted these dll's and the error has solved