Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

0xe000032d Consistency check of the snapshot for the Microsoft Exchange transaction log has failed

Created: 20 Sep 2008 • Updated: 02 Mar 2009 | 7 comments

I just wanted to comment on this error: "0xe000032d - The consistency check of the snapshot for the Microsoft Exchange transaction log has failed." I recently started getting while backing up Exchange 2007. Symantec has the following document on this error: http://seer.support.veritas.com/docs/285294.htm.

 

While that document may be valid in general, there is also a very new bug in Exchange 2007 SP1 Rollup 4 (Released 9/9/2008 under KB 952580, this has already been pulled from the Microsoft site for causing several bugs) which is also causing this to occur. My Backup Exec backups not only started to fail with the error above, but I realized that it was Microsoft-related because even the VSS (Volume Storage Service) was having trouble and giving me the following error: Event ID: 305 One or more errors were detected while validating the transaction log files in 'c:\random_database_name\' with a base name of 'E00'. Transaction log file validation failed with error code -1811 (0xfffff8ed).

 

This and other similar Microsoft error messages are covered in the following blog entries by one of the Microsoft Exchange 2007 engineers: http://msexchangeteam.com/archive/2008/09/11/449787.aspx.

 

I will post the solution as given in the above blog in case it ever disappears, although more information is given in blog, including screen shots, and a forum discussion, so it is still worth a read.

 

The solution is:

  

1) Uninstall the rollup from "View Installed Updates" in Windows Server 2008 or "Add/Remove programs" in Windows Server 2003.

  

2)If the server also has the CAS role, open the web.config file located at <Exchange Install folder>\Client Access\exchweb\ews using an editor like Notepad.exe.

  

3) Replace all instances of %ExchangeInstallDir% with the actual path of the Exchange installation folder. E.g. If you have installed Exchange in D:\Program Files\Microsoft\Exchange Server replace %ExchangeInstallDir% with D:\Program Files\Microsoft\Exchange Server\.

  

Here is a line in the web.config file.

  

Before

  

<codeBase version="0.0.0.0" href="file:///%ExchangeInstallDir%bin\Microsoft.Exchange.Common.IL.dll"/>

  

After

  

<codeBase version="0.0.0.0" href="file:///D:\Program Files\Microsoft\Exchange Server\bin\Microsoft.Exchange.Common.IL.dll"/>

 

Restart W3SVC service

Message Edited by Kevin Cotreau on 09-20-2008 08:52 AM

Comments 7 CommentsJump to latest comment

Kevin Cotreau's picture

One more thing: I could not uninstall the rollup because I had previously deleted the hidden uninstall directory for Rollup 3 (not 4). If you have issues with a Microsoft patch, you can call and receive free PHONE support from them. This free support is only for service packs, patches, and hotfixes.

 

Also for those who are tempted to do this, I actually created a new Exchange Storage Group and database and moved my mailboxes, but it did not help.

Message Edited by Kevin Cotreau on 09-20-2008 09:41 AM
Kevin Cotreau's picture

After implementing the solution posted, I was still getting 1309 and then 1310 warnings.

 

The 1309 errors are caused by %ExchangeInstallDir% not being replaced by C:\Program Files\Microsoft\Exchange Server\ in the web.config file. I had missed two of them due to nulls when I used Wordpad to do a global search and replace so I was still getting that error.

The 1310 errors are caused by the null characters in the web.config. You can open web.config with Microsoft Wordpad. Each null has to be replaced with the correct character manually. The 1310 error shows which line to look in, but there will certainly be more nulls below that first one.

 

In Wordpad, the nulls appear as little boxes. I could not find a way to search for them with any program I have, so you just have to hunt them down line by line and using the 1310 errors as guidance for any you may miss (since they list the line in the web.config file where it bombs out).

nilesf's picture

I am getting the same error on Exchange 2010 running on Windows Server Enterprise Edition R2 x64. I am running Backup Exec 2010 and per Symantec's Document ID: 285294 and still get the error. I am however having some difficulties checking the consistency of the transaction logs.

Please advise,
Niles

CraigV's picture

Open up a new call...more people will check it out and be able to help you Niles!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

KCTS Television's picture

Reading this thread a few days ago, with Exchange 2007 sp1, I upgraded to the current SP1 rollup, 11, but it didnt' fix the problem. Yesterday I upgraded to sp2. The problem continues unabated.

Evidently the problem is not limited to sp1 rollup 4 (or 3.)

Any other suggestions?

vtek63's picture

I have a similar problem with BackupExec 2010 R2 and Exchange 2010 SP1 with Update Rollup 1.

 

It started after I applied SP1. Update rollup 1 didn't help either.

 

anyone else?

CraigV's picture

Hi there,

 

Please open a new thread on your query. THis thread is dead.

 

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...